Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to follow the instructions found here apxs cannot install mod_cloudflare on centos when I run the command rpm -ivh mod_cloudflare-1.1.1-1.x86_64.rpm the server returns the error:

error: Failed dependencies: apache2 is needed by mod_cloudflare-1.1.1-1.x86_64

Note.. I already HAVE Apache installed and configured:

yum install httpd httpd-devel
Loaded plugins: fastestmirror, priorities, security, update-motd, upgrade-helper
Loading mirror speeds from cached hostfile
 * amzn-main: packages.us-east-1.amazonaws.com
 * amzn-updates: packages.us-east-1.amazonaws.com
Setting up Install Process
Package httpd-2.2.23-1.25.amzn1.x86_64 already installed and latest version
Package httpd-devel-2.2.23-1.25.amzn1.x86_64 already installed and latest version
Nothing to do

Like-wise attempting to install Apache2 yields the following:

yum install Apache2
Loaded plugins: fastestmirror, priorities, security, update-motd, upgrade-helper
Loading mirror speeds from cached hostfile
 * amzn-main: packages.us-east-1.amazonaws.com
 * amzn-updates: packages.us-east-1.amazonaws.com
Setting up Install Process
No package Apache2 available.
Error: Nothing to do

I'm running Amazon Linux, any ideas?

share|improve this question

1 Answer 1

I believe this is a SuSE package and not a CentOS/RedHat package since the dependency is to apache2 instead of httpd.

In the linked thread the asker of the question also seems like he did not install the RPM in the end.
You are probably better off following the manual installation guide on cloudflares site for mod_apache:
http://www.cloudflare.com/resources-downloads

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.