Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am unable to install php5-apc.

I don't seem to get any errors.

root@applications-server-1:~# aptitude install php5-apc
The following NEW packages will be installed:
 php5-apc{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 57 not upgraded.
Need to get 64.6 kB of archives. After unpacking 168 kB will be used.
The following packages have unmet dependencies:
 php5-apc : Depends: php5-common (= 5.3.22-1~dotdeb.0) but 5.4.6-1ubuntu1.1 is installed.
The following actions will resolve these dependencies:

 Keep the following packages at their current version:
 1)     php5-apc [Not Installed]                           



 Accept this solution? [Y/n/q/?] Y
 No packages will be installed, upgraded, or removed.
 0 packages upgraded, 0 newly installed, 0 to remove and 57 not upgraded.
 Need to get 0 B of archives. After unpacking 0 B will be used.

 root@applications-server-1:~# aptitude install php5-common
 No packages will be installed, upgraded, or removed.
 0 packages upgraded, 0 newly installed, 0 to remove and 57 not upgraded.
 Need to get 0 B of archives. After unpacking 0 B will be used.

Here is information about my OS:

  • Distributor ID: Ubuntu
  • Description: Ubuntu 12.10
  • Release: 12.10
  • Codename: quantal

I am using PHP-FPM (PHP Version 5.4.6-1ubuntu1.1).

So can I do to install PHP5-APC?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Remove the dotdeb.org repository from your apt sources. This repository was designed for Debian systems and is not intended for (and does not work with) Ubuntu.

share|improve this answer
    
I was able to install PHP with it. It's just PHP-APC that I can't install. Plus isn't Ubuntu bested on Debian? –  jnbdz Mar 11 '13 at 19:41
2  
You were lucky the first time, that is all. Your luck ran out. –  Michael Hampton Mar 11 '13 at 19:47
    
@Jean-NicolasBoulayDesjardins then you were lucky. Ubuntu includes much newer packages than Debian uses. Also, it appears that you have Ubuntu's PHP5.4 installed rather than dotdeb's PHP 5.3 –  DerfK Mar 11 '13 at 19:48
    
It works now, thanks. –  jnbdz Mar 11 '13 at 21:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.