Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm on Linux 3.6.11 with ZFS on Linux 0.6.0rc11.

I have a large ZFS pool with three subpools:

zpool1
    zpool1/backups
    zpool1/graphite
    zpool1/log_backups

The machine rebooted last night, for no obvious reason. After I was paged and got a shell it was already back up.

I ran zfs mount -a to remount the pools. zpool1/log_backups has data in it, but zpool1/graphite and zpool1/backups are completely empty, and df reports that there's no space in use on those partition.

Unfortunately I didn't have snapshots set up, so that's a no go. I've tried exporting and reimporting, but no change.

What other things could I try? And what data recovery options exist for ZFS? I have seen a few scripts around that dig through fs data structures, but they're all a bit more unpolished and potentially destructive than I'd like at this point.

share|improve this question
    
"...but they're all a bit more unpolished and potentially destructive than I'd like at this point..." - this comment is ironic, considering you chose to put data on ZFS on Linux v0.6.0rc11. You're already deep in "not production ready" territory here. I'm not trying to be snarky - this is seriously exactly what you should have expected to happen. If you want to run ZFS with data you want to keep around, use FreeBSD or an illumos derivative. Period. As for your question, those 'unpolished and potentially destructive' tools are your only hope. Try Max Bruning's post on zdb for a starting point. –  Nex7 Mar 22 '13 at 14:18

2 Answers 2

Hopefully zpool status has something to say. Try running zpool import (without arguments) to list out what pools ZFS found that you can likely re-import.

The file that describes what pools exist on the system should be "/etc/zfs/zpool.cache". If that's corrupted, it would explain why the pools aren't automatically importing.

You can also try the old zpool import <pool name> and see if that helps you out.

share|improve this answer

That's an older release of ZFS on Linux. I'd hate for that to happen to anyone. Did you post to the mailing list?

I would try to understand the nature of the crash, as that's not normal. What type of hardware (server, controller) did you have, and what was your pool setup?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.