Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Note: I am talking about a component previously in Zend Server, but is now a standalone module and open-sourced, and will be bundle with PHP 5.5, it has performance/usability edge over the more widely used APC.

Now here is my problem, I cannot seem to get Zend Optimizer+ work properly with my codeigniter-powered (PHP framework) site, my debug config is as following:

zend_optimizerplus.enable=1
zend_optimizerplus.memory_consumption=128
zend_optimizerplus.interned_strings_buffer=8
zend_optimizerplus.max_accelerated_files=4000
zend_optimizerplus.revalidate_freq=10
zend_optimizerplus.fast_shutdown=1
zend_optimizerplus.enable_cli=1
zend_optimizerplus.optimization_level=0
zend_optimizerplus.error_log=/var/log/zendop.log

Once ZO+ is enabled, I started to see php-fpm logs such as these (but nothing else, no segfault error, no entries in ZO+ error log):

[13-Mar-2013 00:58:45] WARNING: [pool www] child 6734 exited with code 1 after 176.326628 seconds from start
[13-Mar-2013 00:58:45] NOTICE: [pool www] child 6761 started

Basically php worker process were stopped and restarted. And all page appear to be outputing only partially. I turned on php error display with error_reporting(E_ALL & ~E_NOTICE); but still don't see any error from PHP itself.

All I can find in Nginx log were entries like:

2013/03/13 00:22:47 [error] 1761#0: *14 readv() failed (104: Connection reset by peer) while reading response header from upstream, client: [my ip address], server: [my server name], request: "GET /leave HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: [my host name].

2013/03/13 00:22:47 [error] 1761#0: *17 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: [my ip address], server: [my server name], request: "GET /leave HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: [my host name].

I can't seem to find much insight regarding what were happening, and I can confirm the site works without ZO+ fine, and ZO+ source appear to compile and install correctly (make test also passed correctly, though there aren't many tests to run).

Anyone had experience with Zend Optimizer+? I am surprised to see no mention of soon-to-be PHP-bundled module anywhere on this site.

php -v

PHP 5.3.10-1ubuntu3.5 with Suhosin-Patch (cli) (built: Jan 18 2013 23:40:19)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies

nginx -v

nginx version: nginx/1.1.19

(If this post belongs to stackoverflow, please help to migrate, though I am not seeing a programming-related error here.)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

After testing with PHP 5.3/5.4 without the Suhosin patch, I can confirm the original issue is indeed caused by Suhosin, and unfortunately, the common workaround suhosin.simulation = On will not fix such incompatibility with Zend O+.

Details can be found in this github ticket: https://github.com/zend-dev/ZendOptimizerPlus/issues/63, in case you are interested.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.