Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm integrating with a third-party product via its SQL Server 2008 R2 database. In a previous version, I was able to access the database via SQL Server Management Studio and SQLCMD as a Windows administrator using Windows authentication.

The third-party product controls the sa account and keeps the password a secret.

After applying the vendor's latest product update, I can no longer access the database using Windows authentication. I even tried single mode, but no luck.

Here's how I switched to single mode:

net stop MSSQL$FOOBAR
net start MSSQL$FOOBAR -mSQLCMD

That seems to start the database.

C:\>sqlcmd /S .\FOOBAR
Msg 18470, Level 14, State 1, Server WINMAC\FOOBAR, Line 1
Login failed for user 'WINMAC\steve'. Reason: The account is disabled.

Is there a way in? Or is it more likely the vendor has closed a hole and I can't get in?

share|improve this question
    
mssqltips.com/sqlservertip/2682/… –  drcelus Mar 13 '13 at 18:28
    
Nice! It worked. Please add it as the answer and I will accept it. –  Steve Taylor Mar 13 '13 at 18:36
add comment

1 Answer 1

up vote 1 down vote accepted

Using PSExec to connect to an instance using the NT AUTHORITY\SYSTEM account:

http://www.mssqltips.com/sqlservertip/2682/recover-access-to-a-sql-server-instance/

However bear in mind that you may be breaking some contract, just wanted to note it :)

Original author is here

share|improve this answer
    
Thanks. Not to worry about contracts. I don't have a relationship with the vendor (yet), just their customers. Interestingly, once I got in, I realised I no longer needed to make the previously required modifications because the vendor realized the error of their ways, which means I don't have to deploy PsExec to customers. Yay! –  Steve Taylor Mar 13 '13 at 18:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.