Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got two virtual hosts:

tt.my

<VirtualHost *:80>
    ServerName tt
    ServerAlias tt.my www.tt.my
    DocumentRoot /www/full/htdocs/
</VirtualHost>

rem.my

<VirtualHost *:80>
    ServerName rem
    ServerAlias rem.my www.rem.my
    DocumentRoot /www/rem/htdocs/
</VirtualHost>

Both are added to sites available by a2ensite tt.my and a2ensite rem.my. They are in hosts too:

127.0.0.1   tt.my   www.tt.my
127.0.0.1   rem.my  www.rem.my

Now tt.my works as expected, but rem.my gives 403 error, and log shows:

(13)Permission denied: /www/rem/htdocs/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

I'm really stuck, what should I do?

ps: /www/rem/ is available for rw for all.

share|improve this question
    
ps: /www/rem/ is available for rw for all. - Did you make sure to have permissions set for all relevant files (at least .htaccess), and not only for the directory? –  Lukas Mar 13 '13 at 18:34
    
@Lukas I've done chmod -R a+rw /www/rem/ so for the file .htaccess to I guess. But - in tt - there's no .htaccess at all! –  k102 Mar 13 '13 at 18:38
    
Have you tried moving/renaming .htaccess? This way, it shouldn't be recognized by Apache any more. If there still occurs the same error, something more serious might be going on. You should also check permissions with ls -lA /www/rem/ or stat /www/rem/.htaccess. You can never be sure until you checked it. –  Lukas Mar 13 '13 at 18:54
    
@Lukas the problem was in permissions... I will now check it twice to be kind of shure. Thanks for your help! –  k102 Mar 14 '13 at 10:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.