Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having trouble connecting to a remote server with X2GO using a DSA key. Connecting works fine over SSH, but when I try to connect with X2GO, it goes immediately to the username/password box and doesn't want to use the private key I specify in the options. If I select "Try auto login" it appears to try to connect and then I get the following error:

No public key matched
Access denied. Authentication that can continue: publickey

It was working previously, but I reinstalled the client OS and since then I am unable to connect. I copied all of the SSH keys over from the previous installation.

I also tried deleting my ~/.ssh/known_hosts file and adding the key to ssh-agent with no success, but the key is definitely added correctly:

$ ssh-add -l
1024 b9:3d:e5:ef:48:ea:fc:c6:6e:45:89:b5:35:e7:58:39 server.com_dsa (DSA)

Note, if I enable password authentication on the server, I can connect fine, however I would like to use publickey. Any ideas how I can connect with public key authentication?

share|improve this question
add comment

1 Answer 1

Which server/client combination are you trying?

When I use a OSX client against an Ubuntu server, everything works fine. Just do the typical copying of public keys to ~/.ssh/authorized_keys on the server.

When I use a Windows client against an Ubuntu server, it works, but is flaky/buggy.

For the latter, you need to follow the instructions here. Essentially, you need to run:

C:\Program Files\x2goclient>ssh-keygen.exe -t dsa

Then get the key into ~/.ssh/authorized_keys on the server.

You also need to pay attention to specifying the corresponding private key file when configuring a specific connection on the windows client.

In the present Windows client, it will prompt me, unnecessarily, to Enter passphrase to decrypt a key three times, pause a bit, and then let me into the server. Everything seems to work fine until I log out, after which the client hangs/crashes.

This client is build 4.0.0.3 on Windows 8.

share|improve this answer
    
It turns out, on the server, I was using %h/.ssh/authorized_keys2 instead of %h/.ssh/authorized_keys in my sshd_config file, so I was adding the keys to the wrong file. However, I can now only connect if I previously add the key to ssh-agent and not by simply specifying the key in the x2go client options. –  Mike Apr 29 '13 at 16:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.