Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Up until today I was able to remote desktop into my windows server 2008 r2 virtual machine running in Azure and I was messing around with the settings for remote desktop session timeouts and now I get this message "remote logins are currently disabled" even when I try to login with an administrator account. I was thinking I could try the windwos 7 remote administration tools but I am unable to connect to machine using the public virtual ip address.

I am wondering what is the best route to take to re-enable remote logins from either command line, remote tools, or whatever.

share|improve this question
    
What is the status of the VM in the Azure dashboard? If you restart/resize the VM does the problem still persist? –  shiitake Apr 4 '13 at 19:45
    
To answer your question, yes the problem still persisted after I restarted the VM. –  Breadtruck Apr 5 '13 at 20:10
add comment

1 Answer

up vote 2 down vote accepted

To fix my issue I had to create a new 2008 R2 VM. I also included both VMs in a virtual network so that the machines could see each other. Then I had to use the remote server management tools to connect up to the remote desktop services on the disabled server.

Under RD Session Host Configuration Properties

I had checked "Allow Connections, but prevent new logons" ... after setting it back to "allow all connections" I was able to remote into the machine again. So even though I had shut down the machine and restarted, that never cleared it up. Basically I was trying to limit one session per user, but the settings didn't work the way I thought it would. I guess I should have read up on Remote Desktop management before I did anything.

share|improve this answer
    
good to hear you figured it out. –  shiitake Apr 8 '13 at 17:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.