Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have configured and am using a NFS share on a Windows 2008 server. I am copying files from a Unix server using anonymous access. What I cannot figure out is how to get the file permissions working on the Windows side. I cannot rename or copy the files without editing the permissions for each file individually. I have set the permissions on the containing folder, but no new files copied inside the folder inherit the folder's permissions.

How do I get the permissions to be the same for all new files that are added to that folder?

share|improve this question
add comment

2 Answers

There are a few things that could be in play here, but it's almost always one of the two below causes

  1. It's a network share, so make sure the "sharing" permissions settings aren't in conflict with your NTFS permissions. (Best practice is to allow Everyone full access in the share permissions and control access with the NTFS permissions).

  2. Ensure the permissions are set to propagate down from the root (or parent folders, as appropriate). From the folder context menu, Properties -> Security tab -> Advanced button -> Permissions tab -> Change Permissions button -> Edit... button. As in the screenshot below, if you want the permissions to apply to child objects, you need to have it applied to the appropriate subset (which is usually This folder, subfolder and files), rather than This folder only.

Permissions dialogue

And of course, depending on your use-case and desires, you may wish to use the option to replace the permissions on all child objects with the ones you're defining, but obviously, be careful, and aware that it can take a while for a lot of files.

share|improve this answer
    
I just checked this and the settings are already done this way. The permissions are supposed to be propagating down but are not. When the files are copied over from unix they are not getting an owner since we are doing anonymous access. I think that is the biggest stumbling block here, but I dont know how to overcome it. –  eptiliom Mar 15 '13 at 12:19
    
@eptiliom Change the owner. You can do so at the root/parent folder and apply the new owner to all subcontainers and objects as well. –  HopelessN00b Mar 15 '13 at 17:16
    
That works for the existing files, but not new ones. –  eptiliom Mar 15 '13 at 20:31
add comment

Checkout: http://blogs.technet.com/b/sfu/archive/2009/08/28/how-nfs-access-works-over-ntfs-permissions.aspx

The registry key mentioned in the post fixed the inheritance problem for us.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.