Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I run a Win 7 host system with VirtualBox 4.2.10 installed. On VB, there is a CentOS 6.3 with an Apache. Now, from my VirtualBox I want to access the internet to use yum, wget aso. and from my host I want to reach my Apache instance. I think this setup is pretty common, but I can't find a way to figure it out correctly.

What might be of importance is that I use WLAN.

What I did is set my VB NIC to bridged with the name Intel Centrino Advanced-N 6230. The adaptor type is Intel Pro/1000 MT Desktop (82540M). Promiscuous mode is on deny and the cable is connected.

In my global settings, I have a virtual network interface which is host only. I don't really get why. I dont' know how to configure this, but VB set the IP to 192.168.41.1 with DHCP deactivated. This NIC is also visible in my Win7 network configurations.

My CentOS eth0 has the static IP 192.168.56.2.

I cannot ping google.com from my VB. I cannot ping my VB from my host. Nothing is connected. Help very much appreciated.

share|improve this question
add comment

closed as off topic by Michael Hampton, EEAA, MDMarra, mdpc, mgorven Mar 18 '13 at 16:46

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 0 down vote accepted

Seems like VirtualBox did not add an bridged adapter to my Win machine as it is ought to.

However, I solved it by configuring one VirtualBox adapter to use NAT and the other one to use host-only. Both use DHCP. My virtual network card is configured as host-only.

Now, I have two interfaces in linux. eth0 is the NAT one, which has an IP of 10.0.2.15 and eth1 (which I had to set up manually) has an IP of 192.168.56.101.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.