Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just made a change to my PHP.ini file. (my Linux dist is CentOS). I figured I need to restart apache for that to take effect so I issued the command:

service httpd restart

When doing that I get this error.

Stopping httpd:                                            [FAILED]
Starting httpd: httpd: Syntax error on line 196 of /etc/httpd/conf/httpd.conf: 
Cannot load     
/etc/httpd/modules/ into server: 
cannot open shared object file: No such file or directory

I'm not too well versed in Linux so I'm not sure what to do next.

share|improve this question
BTW, I've restarted my httpd service several times before. So this is a new error. I've install some packages with yum recently. So maybe that messed up something. – Thread7 Mar 17 '13 at 0:09
I imagine I can comment out those offending lines of httpd.conf. However, am I messing up something else by doing that? – Thread7 Mar 17 '13 at 0:10
More detail please. What is on line 196 of your httpd.conf and what change did you make to your php.ini file? – Dave Mar 17 '13 at 0:31
@Thread7 Please add some of your httpd for us to look at, otherwise we can't help. – Jacob Mar 17 '13 at 1:08
Check two things - 1. Syntax of httpd.conf using -t flag in httpd executable, 2. Is /etc/httpd/modules/ available ? – Abhijeet Kasurde Mar 17 '13 at 2:12
up vote 0 down vote accepted

From the comment you posted it appears that Apache can't load the module that the conf is telling it to import. As far as I can recall certain editions of RHEL/CentOS don't have this included by default. Try commenting it with a # at the beginning of the line. Otherwise try rebuilding Apache with the module.

share|improve this answer
Yes, commenting it out worked. I guess I'll live without it for now. – Thread7 Mar 18 '13 at 19:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.