Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Were migrating to a hosted exchange service from rackspace.com from an in-house exchange server.

Outlook 2007 on the LAN where the in-house exchange server is located connecting to the hosted exchange mailbox takes painfully long (almost 4 minutes) before it's connected to hosted exchange box.

Outside the LAN from my home DSL 3000 down/512k up and from a verizon EVDO modem (even slower) Outlook connects within 10 seconds.

Is the exchange server on the LAN interfering at all? I've tried dismounting the stores and disabling the exchange services and it doesn't make a difference.

share|improve this question
add comment

4 Answers

up vote 4 down vote accepted

I discovered a setting that made everything better. In Outlook in the Account Settings -> More Settings -> Connection tab -> Exchange Proxy Settings.

Check "On fast networks, connect using HTTP first, then connect using TCP/IP"

So Outlook 2007 considered our LAN as a "fast network" and my home as slow, hence why I didn't see these delays outside

share|improve this answer
add comment

Have you looked at turning off Cached Mode on Outlook? This does interefere with some functionality (like some of the Junk mail settings) but it has tremendously sped up my connections from 2-3 minutes down to about 20 seconds.

It turns out that Cached mode (which unfortunately is required for just about every other "value add" feature in Outlook) causes the Exchange-to-Outlook syncronization process to shift into hyperdrive; Outlook and Exchange begin to furiously sync all of the mailboxes you have, regardless of size. Turning this off causes the sync to occur on an as-needed basis and all of that background activity simply disappears.

share|improve this answer
    
Before the setting above, cached mode on or off didn't make much difference. The delay was all in starting and connecting, once connected it was better. This setting improves on connected performance to. As an aside, we've not had good experience with cached mode on when multiple people access the same mailbox. (In our case a department level mailbox). Randomly a message would get duplicated many times. We do a lot of subject renaming of messages and my things was the synchronization routines were not working well. –  David Steven Aug 1 '09 at 20:37
    
In either case, good to hear that it worked! As we are slowly transitioning people to Exchange, this would be good info to keep in mind. –  Avery Payne Aug 1 '09 at 21:48
add comment
  1. Memory used up (possible memory leak)
  2. Disk space
  3. Anti-Virus on Outlook running
  4. Anti-virus found a virus on the Exchange server
  5. Look at logs
  6. Run performance monitor
  7. May have a mass mail out been sent so queues are full or e-mail stuck in queues
  8. DNS down
  9. Exchange topology issue Exchange server looking at another DC site for DNS external to the exchange server

Cheers Marc

share|improve this answer
add comment

What is the Clents ISP speed? I have found that my clents who have a Internet connection that has a slower upload speed of 512kb/s or less have a hard time connecting to my Exchange box via RCP over HTTP (aka Outlook Anywhere).

Try running outlook like this (outlook.exe /rcpdiag) and you will see what I mean.

If that is the case I recommend just going with OWA for those clients unless you can get a faster connection for them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.