Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have configured DNS Server on RedHat 6.1 OS and bind version is bind-9.8.2-0.10.rc1.el6_3.6.x86_64. My DNS server is working properly (Tested by dig and nslookup commands).

The issue is whenever I have keep this server in /etc/resolv.conf in client as a primary server, I am not able to get the response from second and third DNS servers which I have added in the /etc/resolv.conf. If I keep this is a second/third DNS server I am not getting the response from this server. I am only getting the response whenever I kept the single DNS server in /etc/resolv.conf.

share|improve this question

3 Answers 3

This is expected behavior. Having multiple DNS servers in resolv.conf does not mean "try each server until you get a hit". It means "try the first server, but if you don't get a response then try the next".

So if your DNS server has records for only your internal machines and does not forward requests to an outside DNS server, then looking up something external like google.com will result in a "not found" response. Since "not found" is a response, the client gives up because your DNS server responded.

share|improve this answer

Try adding the rotate option into the options section.

rotate sets RES_ROTATE in _res.options, which causes round-robin selection of nameservers from among those listed. This has the effect of spreading the query load among all listed servers, rather than having all clients try the first listed server first every time.

Listed here in the man pages.

share|improve this answer
    
Thanks Nick I tried that one also but no luck :( –  sankar Mar 18 '13 at 14:54

What are you after exactly? My guess is that you want "forwarders" + "forward first" in order to resolve local/non local hosts.

Modern BIND also offers views and split bran DNS for that - heavy doc perusal required.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.