Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

have an Asus Sabertooth X79.

I often get corrupted files. I checked the RAM, but memtest finds no errors. To avoid the possibility of disk errors, I tried copying files to tmpfs.

If I copy from the network, I get md5sum mismatches about once in 10 times using a 6Gb file. Copying from RAM to RAM, I didn't get mismatches.

I get a very high number of errors in ifconfig (compared to others PCs I just took as reference, which have 0 with much more traffic). Here is an example

RX packets:13972848 errors:200 dropped:0 overruns:0 frame:101

The motherboard is new, but do you think there're some problems with it? What could I use to test the (integrated) network adapter? What else do you think I should double check?

Setting the affected NIC to a slower speed with ethtool stops the errors.
The funny thing is that if I plug the same LAN cable into another NIC on the same PC set at 1Gbit, that NIC gives no errors.

share|improve this question
    
Do you have the ethtool -S ethX output on the previous NIC. Just to be sure where the errors are. Pastebin it. Also, please elaborate on the issue on 2nd NIC. tcpdump will tell you where the time throttle comes into play but putting own tcpdump to public is avoidable. –  Soham Chakraborty Mar 18 '13 at 17:28
    
Can you clarify whether this is in a professional environment (office, business, etc.) or a home environment (personal machine)? –  voretaq7 Mar 19 '13 at 16:58
    
It is a University laboratory –  Fabio Dalla Libera Mar 19 '13 at 17:14

2 Answers 2

up vote 5 down vote accepted

I would start by changing out the patch cable. If that doesn't work, I'd try a different port on the switch to see if that makes any difference. I'll assume that your kernel is up to date, so it's unlikely to be a driver issue, but that would be easier to test if any of the other computers that are working are using the same MB, or at least the same on-board NIC.

You might also check to see if there is updated firmware for the NIC, or (less likely to help) the BIOS.

share|improve this answer
    
Thank you. I update the BIOS. I have no other pc with the same MB. I tried another cable coming from another switch (which gives no problems in other pcs). The kernel is 3.2.0-38 –  Fabio Dalla Libera Mar 18 '13 at 14:58
4  
Yeah, at this point, I'd be swapping out the NIC. You could add a NIC to the machine to work around this. You might try building (or buying) a loopback plug and testing to see if the NIC can talk to itself properly. More information on that kind of test in this question: serverfault.com/questions/22984/… –  scottm32768 Mar 18 '13 at 15:06
    
I tried another NIC, it gives a lot of Corrupted MAC on Input. Disconnecting: Packet corrupt lost connection. I noticed that another PC downloads at 11.1MB/s without problems. This pc at 66.0 MB/s. Is there any way to try to limit the speed? –  Fabio Dalla Libera Mar 18 '13 at 16:54
    
Interesting. It might actually be a problem with your switch, since it looks like maybe it can't really handle a gigabit link. You could force the NIC to only connect at 100Mb, and that would certainly slow it down. This page has instructions for that: cyberciti.biz/faq/… –  scottm32768 Mar 18 '13 at 18:11
    
setting to a slower speed by ethtool stops the errors. The funny thing is that if I remove the LAN cable (so obviously coming from the same switch) and plug it to another NIC on the same PC set at 1Gbit, that one gives no errors –  Fabio Dalla Libera Mar 19 '13 at 16:01

Is your switch or your Ethernet card set to a forced baudrate ? Particularly to a full-duplex one ? If so, and if the other end is in auto-negociation mode, you'll end up having this one failing to auto-negociate and set to a half-duplex mode by default.

In such situations, you end up with a lot of collisions that could cause your frame errors.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.