Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a legacy LAMP app that I am suppoting. I am in the process of moving the app from an external hosting provoder (that uses cPanel) to my own server running cPanel. There are some Pear (Perl?) mail functions in this app that are failing when I try and send an email through the app. Here is the error..

Warning: require_once(Mail.php) [function.require-once]: failed to open stream: No such file or directory in /home/abtech/php/Mail/Queue.php on line 100

Fatal error: require_once() [function.require]: Failed opening required 'Mail.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/abtech/php/Mail/Queue.php on line 100

In cPanel under "Software & Services" I have installed Perl Modules and PHP Pair Packages. Also, there is a file mail.php in /home/abtech/php/Mail/, but the file is lowercase, not upper case. Not sure where to go with this, so any help appreciated.

share|improve this question

closed as too localized by Michael Hampton, mdpc, EEAA, mgorven, kce Mar 23 '13 at 17:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
They're not Perl. Might be Pear, could just be a file you forgot to copy... More details about the PHP script are needed. Are you sure there's no Mail.php file on the old server? –  Josh Mar 19 '13 at 11:44
1  
On the old site, temporarily add var_dump(get_included_files()); somewhere to the code. Maybe line 101 of Queue.php. Look at the output and find where Mail.php is. My guess is it's a Zend Framework file. –  Josh Mar 19 '13 at 12:09
    
Wow...just finished 2 hours in PHP hell! Every time I would copy on included file for folder from one location to another to satisfy a require statement, I would get a new require error. Was getting an MDB2 include error and ended up doing 'pear install MDB2-2.4.1' which solved that include problem, and am no longer getting php errors. Not sure if the mail is actually being sent, I will need to research that. Thanks Josh, your comments helped. –  Lumbee Mar 19 '13 at 14:20
    
Sure thing. Be sure to answer your own question with what you did that actually solved it, and accept your own answer so others know you aren't still looking for an answer to this. –  Josh Mar 19 '13 at 14:22

1 Answer 1

up vote 1 down vote accepted

I ended up doing

pear install MDB2-2.4.1

at the server console to solve my issues.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.