Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am looking at a Cisco switch's log at work and am a bit confused by how verbose it can be at times.

For instance, we use automatic QoS here and I often see this when phones are plugged:

Mar 18 15:22:40: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Fa1/0/9, port's configured trust state is now operational.
Mar 18 15:22:41: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Fa1/0/9, port's configured trust state is now operational.
Mar 18 15:22:42: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Fa1/0/9, port's configured trust state is now operational.
Mar 18 15:22:43: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Fa1/0/9, port's configured trust state is now operational.
Mar 18 15:22:44: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Fa1/0/9, port's configured trust state is now operational.
Mar 18 15:22:45: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Fa1/0/9, port's configured trust state is now operational.

Why does it spam this message six times? This is on a WS-C3750V2-24-PS-S switch. If it makes a difference, there are 5 switches of the sort in one stack running IOS 12.2(55)SE3.

The port's configuration is as follows:

Current configuration : 655 bytes
!
interface FastEthernet1/0/9
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 710
 switchport port-security maximum 3
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 ip arp inspection limit rate 100
 load-interval 30
 srr-queue bandwidth share 10 10 60 20
 priority-queue out 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
 spanning-tree bpduguard enable
 service-policy input AutoQoS-Police-CiscoPhone
 ip verify source
 ip dhcp snooping limit rate 100
end
share|improve this question
    
Can you try this on a non-stacked 3750? I have seen where each 3750 in a stack will log the same message caused by something happening on a single stack member. –  cpt_fink Mar 23 '13 at 5:14
    
I check if it happens on non-stacked ones. Good catch. –  gparent Mar 24 '13 at 3:08

1 Answer 1

I believe that this may be a conflict in the:

auto qos voip cisco-phone 

and the other service policy:

service-policy input AutoQoS-Police-CiscoPhone

I would try removing one of them and see what happens. We've had no issues running only the auto qos in our environment.

From the AutoQoS documentation "Ensure that no QoS policies (service policies) are attached to the interface. This feature cannot be configured if a QoS policy (service policy) is attached to the interface"

AutoQos

share|improve this answer
    
The service policy is applied by auto qos, removing it would be a 'bad thing'. –  cpt_fink Mar 18 '13 at 22:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.