Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Yesterday I was trying to install Ganglia in my virtual machine. After I defined Ganglia as a service I reboot the machine, but after that CentOS won't present the log in menu anymore.

I think it's because Ganglia service is blocking the system from starting properly, because I was able to show the start commands that the OS presents as shown below.

enter image description here

How do I fix that ?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Boot into single user mode and disable the service in other runlevels, then switch to RL3 (or 5) or reboot normally.

share|improve this answer
    
you were right SvenW, with single I was able to to turn off the service, but in which level should I start this service then ? –  Valter Silva Mar 19 '13 at 14:54
    
I found my mistake, at /etc/ganglia/gmond.conf there's debug variabel which was 100, which mean that gonna log out all operation of the gmond process, block the input/output, I just set it to 0, so it will run in background mode. Thank you all! –  Valter Silva Mar 19 '13 at 16:53

From the look of it, Ganglia is started in the foreground and does not allow the boot process to continue. Boot single as SvenW suggested or (if the VM makes it difficult) you can enter interactive boot by pressing 'I' in the first stages of the boot process.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.