Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After upgrading MySQL to version 5.6.10 from version 5.5 I'm getting the following errors when starting MySQL server:

2013-03-19 05:32:38 2666 [Note] /usr/sbin/mysqld: ready for connections. Version: '5.6.10'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MySQL Community Server (GPL)
2013-03-19 05:43:27 2666 [ERROR] Incorrect definition of table mysql.proc: expected column 'comment' at position 15 to have type text, found type char(64).

I checked out the mysql.proc table and the comment field is set to TEXT. I ran mysql_upgrade after the upgrade. I tried running it again with --force after seeing that error, but that didn't fix it.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This question on stackoverflow links to a bug report that mentions:

"start the server with the --skip-grant-tables option to cause it to skip the normal grant table checks, then run mysql_upgrade. ... Then stop the server and restart it normally."

reference URL from the bug report was: http://dev.mysql.com/doc/refman/5.5/en/news-5-5-7.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.