Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have signed up for Office 365 and have set it up to use my current domain - I have verified the DNS etc and done the DNS setup in WHM where I added the new DNS records to the zone.

The problem is when I try to set up an account in Outlook it fails as it cannot find the server settings (there is no error message as such, it just asks to verify the email address is correct which it is).

I went to https://www.testexchangeconnectivity.com and did a test for Office 365 Exchange Domain Name Server (DNS) Connectivity Test - this fails due to:

Attempting to resolve the host name mail.mydomain.com in DNS.
The host name resolved successfully.
IP addresses returned: MY_WHM_SERVER_IP

Testing mx record configuration mx value 'mail.mydomain.com'.
Mx values do not match allowed values.

MX Records don't exist or aren't correctly configured for your domain in Office 365. The MX value
'mail.mydomain.com' doesn't match one of the allowed 
values:mail.eo.outlook.com,mail.protection.outlook.com,mail.messaging.microsoft.com,invalid.outlook.com

Looking in WHM there is an entry for mail in DNS zones which reads:

mail 14440 IN CNAME mydomain.com.

In the connectivity test, should mail.mydomain.com still be resolving to my server IP address? Should I remove the above entry for mail from the DNS zone setup or replace it with something else? If not, any idea what else might be causing it to not find the server settings?

Thanks

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The solution to this for me was three fold.

First off you either need to remove the existing MX record completely from WHM or you can choose Email Routing Remote Mail Exchanger which means it ignores the local mail exchanger and always uses external option. For some reason, setting current MX to 1 and Office 365 didn't work for me and it was always trying to use local.

Additionally, when you add a user to Office 365 you need to login online (i.e. browser) before trying to add them to Outlook. If you don't and you try to setup the account in Outlook using the temporary password it fails.

Whilst Microsoft are not aware of this or why, you MUST include a full stop/period after most of the DNS entries for WHM. For example, for the mx record you are told to enter:

MX  0   @           YOURDOMAIN.mail.protection.outlook.com  1 Hour

To get this work in WHM, you need to use:

MX  0   YOURDOMAIN.COM. YOURDOMAIN.mail.protection.outlook.com. 3600

Note the period after YOURDOMAIN.COM and also after YOURDOMAIN.mail.protection.outlook.com - finally, you need to enter 3600 and not 1 as WHM uses seconds for TTL. @ wouldn't work for me either but YOURDOMAIN.COM. worked fine.

Finally, the TXT value needs to be entered inside quotes - again Microsoft tried to get me to remove them but it only works when they are quoted so

v=spf1 include:spf.protection.outlook.com -all 

should be entered as

"v=spf1 include:spf.protection.outlook.com -all"

for the TXT value.

Hope this helps someone else!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.