Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have problems receiving mails from my security cam

My mailserver is running postfix and dovecot

By checking /var/log/mail.log the output is this

mail postfix/smtpd[1677]: connect from §.tdc.net[§]
mail postfix/smtpd[1677]: match_hostname: §.tdc.net ~? 127.0.0.0/8
mail postfix/smtpd[1677]: match_hostaddr: § ~? 127.0.0.0/8
mail postfix/smtpd[1677]: match_list_match: §.tdc.net: no match
mail postfix/smtpd[1677]: match_list_match: §: no match
mail postfix/smtpd[1677]: send attr request = connect
mail postfix/smtpd[1677]: send attr ident = smtp:§
mail postfix/smtpd[1677]: private/anvil: wanted attribute: status
mail postfix/smtpd[1677]: input attribute name: status
mail postfix/smtpd[1677]: input attribute value: 0
mail postfix/smtpd[1677]: private/anvil: wanted attribute: count
mail postfix/smtpd[1677]: input attribute name: count
mail postfix/smtpd[1677]: input attribute value: 1
mail postfix/smtpd[1677]: private/anvil: wanted attribute: rate
mail postfix/smtpd[1677]: input attribute name: rate
mail postfix/smtpd[1677]: input attribute value: 6
mail postfix/smtpd[1677]: private/anvil: wanted attribute: (list terminator)
mail postfix/smtpd[1677]: input attribute name: (end)
mail postfix/smtpd[1677]: > §.tdc.net[§]: 220 <domain> ESMTP Postfix (Debian/GNU)
mail postfix/smtpd[1677]: watchdog_pat: 0xb84c9470
mail postfix/smtpd[1677]: < §.tdc.net[§]: EHLO localhost
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250-<domain>
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250-PIPELINING
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250-SIZE 10240000
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250-VRFY
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250-ETRN
mail postfix/smtpd[1677]: match_list_match: §.tdc.net: no match
mail postfix/smtpd[1677]: match_list_match: §: no match
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250-STARTTLS
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250-ENHANCEDSTATUSCODES
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250-8BITMIME
mail postfix/smtpd[1677]: > §.tdc.net[§]: 250 DSN
mail postfix/smtpd[1677]: watchdog_pat: 0xb84c9470
mail postfix/smtpd[1677]: < §.tdc.net[§]: QUIT
mail postfix/smtpd[1677]: > §.tdc.net[§]: 221 2.0.0 Bye
mail postfix/smtpd[1677]: match_hostname: §.tdc.net ~? 127.0.0.0/8
mail postfix/smtpd[1677]: match_hostaddr: § ~? 127.0.0.0/8
mail postfix/smtpd[1677]: match_list_match: §.tdc.net: no match
mail postfix/smtpd[1677]: match_list_match: §: no match
mail postfix/smtpd[1677]: send attr request = disconnect
mail postfix/smtpd[1677]: send attr ident = smtp:§
mail postfix/smtpd[1677]: private/anvil: wanted attribute: status
mail postfix/smtpd[1677]: input attribute name: status
mail postfix/smtpd[1677]: input attribute value: 0
mail postfix/smtpd[1677]: private/anvil: wanted attribute: (list terminator)
mail postfix/smtpd[1677]: input attribute name: (end)
mail postfix/smtpd[1677]: disconnect from §.tdc.net[§]

The IP is replaced with §

And the result of postconf -n is

alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
debug_peer_list = §
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
inet_protocols = all
mailbox_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks.regexp
mydestination = mail.<domain>, localhost.<domain>, localhost
myhostname = mail.<domain>
mynetworks = 127.0.0.0/8
myorigin = /etc/mailname
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_recipient_maps =
relayhost =
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions =  permit_mynetworks,
                permit_sasl_authenticated,
                reject_unauth_destination,
                reject_unauth_pipelining,
                reject_unknown_recipient_domain,
                reject_rbl_client bl.spamcop.net,
                check_policy_service inet:127.0.0.1:60000
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/ssl/certs/postfix.pem
smtpd_tls_key_file = /etc/ssl/private/postfix.pem
smtpd_use_tls = yes
virtual_alias_domains =
virtual_alias_maps =    mysql:/etc/postfix/mysql-virtual_alias-maps.cf,
            mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = dovecot
virtual_uid_maps = static:5000

The cam's settings is set to

SMTP Server Name = mail.<domain>
SMTP Server Port = 25
Secure SSL = No
Authentication = Yes
User name = <My mail address>
Password = *******
Sender mail address = <My mail address>
Receiver mail address = <My mail address (for testing)>
Subject = Alarm from Y-Cam
Message = Testing
share|improve this question

2 Answers 2

up vote 0 down vote accepted

according to your session log, postfix does not offer AUTH capability after EHLO, that's probably why your cam QUIT's immediately since it is configured to do SMTP authentication.

Make sure your postfix sasl auth configuration works without the cam first, check dovecot logs as well.

share|improve this answer

Looks like your client asks to QUIT immediately after the EHLO response:

mail postfix/smtpd[1677]: > §.tdc.net[§]: 250 DSN
mail postfix/smtpd[1677]: watchdog_pat: 0xb84c9470
mail postfix/smtpd[1677]: < §.tdc.net[§]: QUIT
mail postfix/smtpd[1677]: > §.tdc.net[§]: 221 2.0.0 Bye

In fact the only input from the client is EHLO localhost then QUIT.

No surprise, postfix is obliging :).

share|improve this answer
    
What is watchdog_pat? As I think it maybe comes from there. And I will add the settings from the cam in about a minute –  The87Boy Mar 20 '13 at 21:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.