Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Sometime before, MyDomain allows CNAMEing of second-level domains, and I naively used that.

Now I thought I had specified everything using an A record, and last night I changed the entry for stornge.com to:

A Record
An A Record (or host name) associates a specific address with a specific IP address (secure.yourdomain.com >> 11.222.333.444)

Host    Points To:  Action
*.linux
3.154.31.225

linux
3.154.31.225

*
50.116.48.189

stornge.com
50.116.48.189

However, I checked this morning, more than twelve hours later, a

(kingdom)jonathan@li393-189:~/alter/alter$ host stornge.com
stornge.com is an alias for haywardfamily.org.
haywardfamily.org has address 24.15.82.204
haywardfamily.org mail is handled by 10 smtp.dnsexit.com.

Maybe I just need to wait longer (12 hours may not meet a 24-48 hour latency), but I thought that before I implemented the changes stornge.com had an A record (not second-level CNAME record) pointing to haywardfamily.org.

I am in the process of repurposing the domain with backwards compatibility added in at the end. However, when I thought I was going to test Gunicorn and Apache ReverseProxy forwarding, I'm stuck on something a little more basic, getting the URL to work. I know I can sidestep the problem for development purposes by adding a line in my /etc/hosts, but I'd like to get stornge.com to not be an alias for haywardfamily.org and for it to have an A record for 50.116.48.189.

How do I do this in MyDomain.com? The webmin interface seems not to show the ?older CNAME?, therefore not providing a way to change or delete the CNAME. (If it is in fact the older CNAME that is at fault, a point on which I am not sure.)

--EDIT--

I'm on Mountain Lion. My attempted change didn't work; I cleared relevant browsing history in Chrome and found stornge.com to redirect to jonathanscorner.com (the existing intended behavior), and www.stornge.com to redirect to jonathanscorner.com. I also tried Firefox, which I usually only use for plugins I don't have in Chrome, and that got the same redirection. The behavior that the haywardfamily.org server is set for, when accessed as stornge.com, is to serve as a tinyurl.com private clone; hence you can go to http://stornge.com/a and get my AI (critique) thesis at http://jonathanscorner.com/ai. It is showing the correct prior behavior.

How can I get stornge.com pointed to the 50.116.48.189 , and if possible, how can I accomplish what I was trying to do with my /etc/hosts file, implement the changes and work on the site while I wait for the official DNS service to work as intended?

--EDIT--

There was something in my httpd.conf that I missed because I was looking in sites-enabled. It is now serving the intended (error) page.

Thanks,

share|improve this question

1 Answer 1

It looks like you have both a CNAME and an A record for stornge.com:

From "dig -t A stornge.com"

;; QUESTION SECTION:
;stornge.com.                   IN      A
;; ANSWER SECTION:
stornge.com.            3600    IN      A       50.116.48.189

And from "dig -t CNAME stornge.com"

;; QUESTION SECTION:
;stornge.com.                   IN      CNAME

;; ANSWER SECTION:
stornge.com.            3398    IN      CNAME   haywardfamily.org.

This is a problem - the CNAME needs to be removed. If it's not showing in their control panel, there are three possibilities:

  1. It's been deleted from their records, but hasn't been updated on their DNS servers yet.
  2. It's been deleted from their records, updated on their DNS servers, but cached elsewhere. That just requires waiting until the caches expire.
  3. Their control panel is broken - in which case you need to contact support.

I tried querying one of your actual DNS servers - ns1.mydomain.com - for both an A record and a CNAME, and got both back, which leaves options 1 and 3. At this point your best plan would be to contact their support and let them figure it out. It's what you pay them for.

share|improve this answer
    
Thank you; how do I delete the CNAME record from MyDomain.com? Thanks, –  Jonathan Hayward Mar 22 '13 at 12:46
    
If it's not showing up in the control panel to delete, then contact their support. Number is right on top of their website: 800-405-7875 –  Grant Mar 22 '13 at 13:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.