Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I already checked all of the answers on stack overflow, but none work!

I am trying to install Apache over IIS (I disabled all IIS sites that are on port 80 and 443). I disabled the firewall.

But, when I install Apache, I get the following error:

(OS 10048)
Only one usage of each socket address (protocol/network address/port) is normally permitted. : 
make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down Unable to open logs

Maxwell D.

I need help ASAP!

EDIT: Output of netstat -an|find "TCP"|find /v /c "asdadasd" :

C:\Users\Administrator>netstat -an|find "TCP"|find /v /c "asdadasd"
172

EDIT 2: Output of sc query W3SVC :

C:\Users\Administrator>sc query W3SVC

SERVICE_NAME: W3SVC
    TYPE               : 20  WIN32_SHARE_PROCESS
    STATE              : 1  STOPPED
    WIN32_EXIT_CODE    : 1068  (0x42c)
    SERVICE_EXIT_CODE  : 0  (0x0)
    CHECKPOINT         : 0x0
    WAIT_HINT          : 0x0
share|improve this question
    
Could you post the output of netstat -an|find "TCP"|find /v /c "asdadasd" ? I want to see the number of TCP connections. –  Mircea Vutcovici Mar 22 '13 at 19:19
    
What does sc query W3SVC return? –  jscott Mar 22 '13 at 19:45
    
Again, it was that I didn't look too far for the problem. It actually was some old piece of software I installed a VERY long time ago, but forgot to uninstall. It had a built in web server that used port 80. Thanks to the command that Mircea Vutcovici posted I found the program and removed it. –  MDTech.us_MAN Mar 23 '13 at 17:14
add comment

2 Answers

up vote 0 down vote accepted

Check that there is nothing listening already on 0.0.0.0:80:

netstat -anb > netstat.txt
notepad netstat.txt

Check if in apache configuration you define a listener for 0.0.0.0 only once. Search for Listen directive. Listen 0.0.0.0:80 is the same as Listen 80.

See: http://httpd.apache.org/docs/2.2/mod/mpm_common.html#listen

share|improve this answer
add comment

You need to find out which program/service is using port 80 on your local server. One way to do this is to use the tcpview utility, it will give you a list of all ports open and the program related to that port. In the TCPView window, sort by 'local port', look for port 80 and on the left pane you will see the process. That way you can stop or disable the server, the tool even allows you to kill the process.

share|improve this answer
    
I already know it is PID 4 (System) –  MDTech.us_MAN Mar 22 '13 at 20:05
    
Do you have "SQL Server Reporting Services (MSSQLSERVER)" running? If so, stop that service and see if that frees up the port. –  Daniel t. Mar 22 '13 at 20:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.