Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 2003 R2 x64 Enterprise Edition server that is backed by a SAN that has a disk that I need to expand.

The SAN management interface notes that this drive is sized at 110 GB. Windows is reporting that it’s only at 70 GB. I thought that I’d just extend the volume, but wanted to confirm that Windows saw the partition.

When I go to Disk Management, the MMC says “Unable to connect to the Logical Disk Manager service.”

I tried through CLI (diskpart) but get the same error message.

There are errors in the System Event log that indicate these activities

The Logical Disk Manager Administrative Service service terminated unexpectedly. It has done this 100 time(s).

VDS fails to launch provider {F96544E6-5C8D-47B9-AA6E-FD19AB278629}. Error code: 8004241B@02000012

Is it possible to recover from this error without a reboot? Do you have any thoughts about the cause?

share|improve this question
1  
I looked at the GUID in DuckDuckGo.com and found these possible causes and resolutions: bit.ly/XHxhwE –  Max Vernon Mar 27 '13 at 20:21

1 Answer 1

up vote 1 down vote accepted

My initial thoughts to the 'without a reboot' bit is no! 2003's disk management can be a bit temprimental at times (We had a 2003 (32-bit!) file server with approx 35 SAN LUNs and many connected users. We had the occasional issue with expansions, and even seeing new LUNs.

For most reliability, we did the following procedure:

  1. expand SAN LUN using SAN tools
  2. open Device Manager and in the menu, click on Scan for hardware changes
  3. Log out
  4. Log back in
  5. Open Disk Manager and check for new LUN / free space (Sometimes requires a scan for disks)
  6. Extend using Disk Manager GUI or diskpart

So try logging out and back in, it may do the trick but I would guess not seeing as your disk management service is not startable.

Check to see if you have the following hotfix (I'd guess you're fully up to date already, seeing as it is an older O/S) - http://support.microsoft.com/kb/957271

if not, try applying the above.

share|improve this answer
    
Thank you. That hotfix is not applied so we'll do that during a maintenance window. I don't know if it'll solve every problem, but I'm going to accept this based on the fact that it's the best lead that I have so far. –  swasheck Apr 4 '13 at 19:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.