Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a big problem.

i try to start mysql in ubuntu, butI have this error:

130323  0:13:55 [Note] Plugin 'FEDERATED' is disabled.
130323  0:13:55 InnoDB: The InnoDB memory heap is disabled
130323  0:13:55 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130323  0:13:55 InnoDB: Compressed tables use zlib 1.2.3.4
130323  0:13:55 InnoDB: Initializing buffer pool, size = 8.0G
130323  0:13:55 InnoDB: Completed initialization of buffer pool
130323  0:13:55 InnoDB: highest supported file format is Barracuda.
130323  0:13:55  InnoDB: Waiting for the background threads to start
130323  0:13:56 InnoDB: 1.1.8 started; log sequence number 1195255849922
130323  0:13:56 [ERROR] /usr/sbin/mysqld: unknown option '--query_cache_size-128M'
130323  0:13:56 [ERROR] Aborting

130323  0:13:56  InnoDB: Starting shutdown...
130323  0:13:57  InnoDB: Shutdown completed; log sequence number 1195255849922
130323  0:13:57 [Note] /usr/sbin/mysqld: Shutdown complete

This has no sense, because I dont use that in the my.cnf:

    #
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /var/run/mysqld/mysqld.sock
nice            = 0

[mysqld]
#
# * Basic Settings
#
user            = mysql
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
#datadir                = /var/lib/mysql
datadir       = /home/mysql
tmpdir          = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking

#innodb_force_recovery = 3
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address            = 127.0.0.1
#
# * Fine Tuning
#
key_buffer              = 500M
max_allowed_packet      = 128M
thread_stack            = 192K
thread_cache_size       = 8

default-storage-engine = INNODB

# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover         = BACKUP
max_connections        = 75
sort_buffer_size = 4M
join_buffer_size = 4M
table_cache            = 128K
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit       = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
general_log_file        = /var/log/mysql/mysql.log
log-error=/var/log/mysql.err
#general_log             = 1
#
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#
# Here you can see queries with especially long duration
#log_slow_queries       = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id              = 1
#log_bin                        = /var/log/mysql/mysql-bin.log
expire_logs_days        = 10
max_binlog_size         = 100M
#binlog_do_db           = include_database_name
#binlog_ignore_db       = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem

innodb_additional_mem_pool_size = 50M
innodb_thread_concurrency = 8
innodb_flush_method = O_DSYNC
innodb_flush_log_at_trx_commit = 2
innodb_buffer_pool_size = 8G
innodb_log_files_in_group = 2
innodb_log_file_size = 32M
innodb_log_buffer_size = 16M
innodb_file_per_table = 1
innodb_table_locks = 0

[mysqldump]
quick
quote-names
max_allowed_packet      = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer              = 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/

Any ideas? :(

share|improve this question
1  
Fix the typo. Then it should work. –  Michael Hampton Mar 22 '13 at 23:22
    
the typo is the minus sign where equals should be: query_cache_size-128M -> query_cache_size=128M –  user16081 Mar 23 '13 at 0:13
add comment

2 Answers

Check your /etc/init.d/mysql if it's trying to start MySQL with this option.

share|improve this answer
    
ty, in /etc/mysql/conf/ there was a file with that opcion...I didnt make it... –  poormysql Mar 22 '13 at 23:33
    
What's the name of the file and what's the content? It should be working if you fix it to --query_cache_size=128M (although you probably don't need this option at all, as it's overriding the query_cache_size = 16M from your my.cnf). –  etagenklo Mar 22 '13 at 23:36
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  mdpc Mar 23 '13 at 0:17
1  
Question is: "Any ideas? :(" I could also add an "If it is, remove the option" to my answer ;) –  etagenklo Mar 23 '13 at 0:24
add comment

Check your my.cnf file for the options listed in the error logs and comment them out. Start mysql.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.