Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have previously used sendmail from the command line to send a large number of messages and used the -odd flag to defer delivery so that the program puts the emails into the queue quickly and returns to the user while messages are delivered in the background. This is described in the DeliveryMode portion of the man page:

http://www.sendmail.org/~ca/email/man/sendmail.html

The new server I am moving to is using exim and sendmail is aliased to exim, and is choking on the -odd flag. Is there a way to force exim to perform a deferred delivery on a message from the command line and put it into the queue instead of immediately trying to deliver it?

share|improve this question
    
Thanks so much for this, I've been searching for sendmail command line options for delayed sending EVERYWHERE! –  Kevin Jul 14 '13 at 6:58

1 Answer 1

up vote 3 down vote accepted

Have your tried/considered using exim supported -odq? (or exim specific -odqs)

Sendmail's -odd puts messages in queue like -odq and avoids doing any DNS loops.

The Exim command line

-odq This option applies to all modes in which Exim accepts incoming messages, including the listening daemon. It specifies that the accepting process should not automatically start a delivery process for each message received. Messages are placed on the queue, and remain there until a subsequent queue runner process encounters them. There are several configuration options (such as queue_only) that can be used to queue incoming messages under certain conditions. This option overrides all of them and also -odqs. It always forces queueing.

share|improve this answer
1  
If messages will be delivered to remote hosts also -odqs can be interesting. –  dsznajder Mar 24 '13 at 16:31
    
They are actually only being delivered to remote hosts, so I think the distinction offered between odq and odqs is not too important for my use case, but thanks! Appreciate the response, Andrzej! –  Matt Mar 24 '13 at 18:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.