Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a SIP client device connected to my ADSL router, so it is behind a symmetric NAT. My ISP resets the client's IP every 24 hours, it looks like this in the router log:

Mar 26 12:36:56     daemon  crit    pppd[443]: Clear IP addresses. Connection DOWN.
Mar 26 12:36:56     daemon  crit    pppd[443]: Clear IP addresses. PPP connection DOWN.
Mar 26 12:37:06     daemon  crit    pppd[443]: PPP LCP UP.
Mar 26 12:37:07     daemon  crit    pppd[443]: Received valid IP address from server. Connection UP.

Now, when this happens, my SIP client permanently loses ability to register itself at provider (I suspect it still has the old external IP cached). The only way to make it work again, is to restart the modem (or whole router), so the ADSL link is put down and up again; In other words, make this happen (router log again):

Jan 1 00:00:08  user    crit    kernel: ADSL link down
Jan 1 00:00:14  user    crit    kernel: xDSL G.994 training
Jan 1 00:00:25  user    crit    kernel: ADSL G.992 started
Jan 1 00:00:29  user    crit    kernel: ADSL G.992 channel analysis
Jan 1 00:00:36  user    crit    kernel: ADSL link up, interleaved, us=1182, ds=12444
Jan 1 00:00:37  daemon  crit    pppd[443]: PPP LCP UP.
Jan 1 00:00:47  daemon  crit    pppd[443]: PPP LCP UP.
Jan 1 00:00:47  daemon  crit    pppd[443]: Received valid IP address from server. Connection UP.

Of course I can't afford to manually put ADSL link down each time my ISP changes my IP address, just to make the VoIP phone work. So my question is, is there any way to make the SIP client work after the IP reset?

My config is:
Router: D-Link DSL-2640B
SIP Client: Gigaset A-510IP

I have already tried enabling RIP in the router, putting gigaset in DMZ, modifying the "refresh NAT time" value in gigaset config, acivating STUN... none of this helped.

share|improve this question

2 Answers 2

The solution happened to be buying another router... this solved the problem. I still don't know what was the reason of it though.

share|improve this answer

Why not have it unregister before the line goes down.. I'd say the problem is that the REGISTER timeout set by you on the server means that you specifically need to unregister or the server will ignore other requests from you that don't come from the session you have already registered.

Basically you send a REGISTER with a timeout of 0 before the line goes down (I am assuming it goes down at a certain time of night, +/- 30 minutes.. ) and then you can re REGISTER with the new IP.

share|improve this answer
    
Thing is I can't schedule registration events at certain time, I can only modify "Registration refresh time" interval. It was set to 60 seconds, I guess I can try setting it to some high value, but won't it cause problems with everyday use (like, the provider will de-register me often because of time-out)? –  fh_spitfire Mar 26 '13 at 13:08
    
Yeah, I was looking through your manual, when you send the original REGISTER I was hoping you could set a lower time, but I can't see any way to reduce that time on the client side. The refresh time I think is more for NAT, to keep the port open, instead of making sure your registration is up to date. –  NickW Mar 26 '13 at 13:16
    
There are actually two different settings: Registration refresh time and NAT refresh time. –  fh_spitfire Mar 26 '13 at 13:23
    
Interesting, I wonder what it actually sends.. –  NickW Mar 26 '13 at 13:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.