Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using Fedora 17 with Bind 9 installed, trying to configure a DNS and I already solved a problem:

Bind DNS configuration, dig command don't resolve name

Now ipv4 and ipv6 mapping works, also reverse ipv4 mapping works, but the problem is with reverse ipv6. In my named.conf file there is this zone:

zone "3.1.0.0.0.0.0.0.0.0.0.2.ip6.arpa" IN {
    type master;
    file "reverse6.zone";
};

And this is the reverse6.zone file:

$TTL 48h
$ORIGIN 3.1.0.0.0.0.0.0.0.0.0.2.ip6.arpa.
@       IN      SOA     gruppo13.labreti.it. master.gruppo13.labreti.it. (
    2013032511
    1d
    2h
    4w
    1h
)
    IN      NS      gruppo13.labreti.it.
1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0 IN  PTR gruppo13.labreti.it.
2.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0 IN  PTR dns.gruppo13.labreti.it.
8.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0 IN  PTR www.gruppo13.labreti.it.
3.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0 IN  PTR mail.gruppo13.labreti.it.

With dig I am able to find an ip6 address, but if I do the reverse:

$ dig -x AAAA 2000:0:d::1

I don't get answer, and this is the dig output:

; <<>> DiG 9.9.2-rl.028.23-P1-RedHat-9.9.2-5.P1.fc17 <<>> -x AAAA 2000:0:d::1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 43454
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;AAAA.in-addr.arpa.     IN  PTR

;; Query time: 17 msec
;; SERVER: 192.168.13.100#53(192.168.13.100)
;; WHEN: Tue Mar 26 14:02:39 2013
;; MSG SIZE  rcvd: 46

;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 17670
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;2000:0:d::1.           IN  A

;; Query time: 13 msec
;; SERVER: 192.168.13.100#53(192.168.13.100)
;; WHEN: Tue Mar 26 14:02:39 2013
;; MSG SIZE  rcvd: 40
share|improve this question
    
You're not looking up an address within the zone you specified (which is also an invalid IPv6 network). If you obscured something, please edit your question. –  Michael Hampton Mar 26 '13 at 13:11
add comment

1 Answer

up vote 4 down vote accepted

Your command is invalid. You are looking up the inverse of AAAA:

;; QUESTION SECTION:
;AAAA.in-addr.arpa.     IN  PTR

and the IPv4 address of 2000:0:d::1:

;; QUESTION SECTION:
;2000:0:d::1.           IN  A

What you want is to drop the AAAA from your command (and fix the address):

dig -x 2000:0:13::1

Which will send the right question:

;; QUESTION SECTION:
;1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.3.1.0.0.0.0.0.0.0.0.0.2.ip6.arpa. IN PTR

And remember that 2000:0:13::12000:0:d::1!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.