Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to let anonymous users login and upload files to a directory "/srv/ftp/dropbox" but not see or download anything.

Can login as anonymous but when I try and upload a file with the following command I get these error's.

put /home/username/TestFTP /srv/ftp/dropbox/TestFTP  
229 Entering Extended Passive Mode (|||30094|).  
553 Could not create file.   

The "/etc/vsftpd.conf" file has this in it, If its not on list its commented out most likely.

write_enable=YES  
dirmessage_enable=YES  
nopriv_user=ftpsecure  
local_enable=YES  
chroot_local_user=YES  
chroot_list_enable=NO  
allow_writeable_chroot=YES  
anonymous_enable=YES  
anon_world_readable_only=YES  
anon_upload_enable=YES  
chown_uploads=YES  
chown_username=username  
anon_root=/srv/ftp/dropbox  
syslog_enable=YES  
log_ftp_protocol=YES  
xferlog_enable=YES  
vsftpd_log_file=/var/log/vsftpd.log  
connect_from_port_20=YES  
ssl_enable=NO  
userllist_deny=NO  
userlist_enable=YES  
userlist_file=/etc/vsftpd.allow_users  

Permissions on the directories are

srv = drwxr-xr-x  
ftp = drwxr-xr-x  
dropbox = drwx-wx---  

Ownership of the 3 folders is set to root right now

The OS i am running is openSUSE 12.2 for more information.

share|improve this question
    
please provide ownership information for the folders –  Alex P. Mar 27 '13 at 15:15
    
Just updated it, still having problems. –  Xnub Mar 27 '13 at 21:14
    
You seem to have made yourself two Stack Exchange accounts. You should have them merged. This will let you edit your own question without having to get approval. –  Michael Hampton Mar 28 '13 at 16:48

2 Answers 2

you are trying to upload to /srv/ftp/dropbox/srv/ftp/dropbox/TestFTP

try just

put /home/username/TestFTP
share|improve this answer
    
Still same error –  Xnub Mar 27 '13 at 14:47

Also check SELinux policies and variables, particularly the following one: allow_ftpd_anon_write

share|improve this answer
    
Was trying this but don't think it is a option for the version i am using or i am missing something. –  Xnub Mar 27 '13 at 14:51
    
What OS are you using? –  slimsuperhero Mar 28 '13 at 8:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.