Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was running a new script and encountered the following error:

Your filesystem or build does not support posix ACLs

So I thought no problem, just add acl,user_xattr to my fstab. It now looks like the following:

UUID=01f6d86f-7840-49af-a4e9-191d6e2aeddc / ext4 relatime,acl,user_xattr,errors=remount-ro 0 1

Did a restart and did a mount to check if everything was ok but it wasn't instead it showed the following:

/dev/disk/by-uuid/01f6d86f-7840-49af-a4e9-191d6e2aeddc on / type ext4 (rw,relatime,errors=remount-ro,user_xattr,barrier=1,data=ordered)

So no acl. Did it manually with

mount / -o remount,acl

But that didnt help. So I'm stuck at the moment. I'm running Debian Wheezy RC1 with an ext4 fs. libacl and libacl-dev are installed.

share|improve this question
    
Are you using a custom kernel without ACL support? –  Artefacto May 13 at 12:12

2 Answers 2

up vote 1 down vote accepted

ext4 has the acl and user_xattrs options enabled by default¹. You would have to use noacl or nouser_xattr to not use them.

http://patchwork.ozlabs.org/patch/102405/

share|improve this answer

On my Fedora 18 system the filesystems show as:

/dev/mapper/vg_machine-LogVol04 on /home type ext4 (rw,relatime,seclabel,data=ordered)

(no acl mentioned) but ACLs do work. I do getfacl xxx and setfacl -m ... xxx without trouble.

What are the exact commands in the script that fail?

Perhaps you should take the issue up with Debian's bugzilla...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.