Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I changed the password of linux user "user123" on my Suse box and noticed that the previously working Samba login that I used to access its home directory from Windows did not change along with it. So I did this to ensure the 2 passwords were the same:

smbpasswd -x user123; smbpasswd -a user123; smbpasswd -e user123
Failed to find entry for user user123.
New SMB password:
Retype new SMB password:
Added user user123.
Enabled user user123.

Afterwards, I noticed that I could no longer access that directory (/home/user123). Windows response when I press for further details was that I "don't have permissions to access \ip.of.samba.share\user123" Here is my smb.conf file:

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2010-07-05
        workgroup = WORKGROUP
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = Yes
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        domain logons = No
        domain master = No
        security = user
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = Yes
        read only = No
        inherit acls = Yes
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

## Share disabled by YaST
# [netlogon]

And, by the way, I have restarted Samba:

/etc/init.d/smb restart
Shutting down Samba SMB daemon  done
Starting Samba SMB daemon   done

Any ideas?

share|improve this question

Why aren't you changing the password that's stored in Windows? The password that is stored in Windows (if it is stored) is the one that authenticates the Windows workstations/user to the samba share. Try changing the password that's stored in Windows instead.

share|improve this answer
Whenever I try to view the directory form Windows it prompts me for a password. When I enter the correct one it balks. – JoeyJoeJoeJuniorShabadoo Mar 27 '13 at 18:50
So, to elaborate, I interpret this to mean that no password is being stored by Windows currently. Presumably, had I been able to authenticate successfully, it would have stored the password I entered, which has been the case in the past. – JoeyJoeJoeJuniorShabadoo Mar 27 '13 at 19:19
It could have a password stored, but that would be your old password, so after trying it, it would prompt you. Are you sure it's not locking the account out with invalid login attempts? – BigHomie Mar 27 '13 at 21:03
It's possible. I have no evidence of that, however. I think this is a major clue: "don't have permissions to access \ip.of.samba.share\user123" – JoeyJoeJoeJuniorShabadoo Mar 27 '13 at 21:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.