Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just followed this tutorial for openVPN: https://help.ubuntu.com/12.04/serverguide/openvpn.html

Sadly, I have trouble to get clients machine connect. This is the log of the client:

Wed Mar 27 12:11:11 2013 OpenVPN 2.3.0 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Mar  7 2013
Wed Mar 27 12:11:11 2013 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Wed Mar 27 12:11:11 2013 Need hold release from management interface, waiting...
Wed Mar 27 12:11:11 2013 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Wed Mar 27 12:11:11 2013 MANAGEMENT: CMD 'state on'
Wed Mar 27 12:11:11 2013 MANAGEMENT: CMD 'log all on'
Wed Mar 27 12:11:11 2013 MANAGEMENT: CMD 'hold off'
Wed Mar 27 12:11:11 2013 MANAGEMENT: CMD 'hold release'
Wed Mar 27 12:11:11 2013 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Wed Mar 27 12:11:11 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Wed Mar 27 12:11:12 2013 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Wed Mar 27 12:11:12 2013 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Mar 27 12:11:12 2013 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Mar 27 12:11:12 2013 Socket Buffers: R=[8192->8192] S=[8192->8192]
Wed Mar 27 12:11:12 2013 MANAGEMENT: >STATE:1364400672,RESOLVE,,,
Wed Mar 27 12:11:12 2013 UDPv4 link local: [undef]
Wed Mar 27 12:11:12 2013 UDPv4 link remote: [AF_INET]74.56.65.49:1194
Wed Mar 27 12:11:12 2013 MANAGEMENT: >STATE:1364400672,WAIT,,,

This is my client configuration file:

### Client configuration file for OpenVPN

# Specify that this is a client
client

# Bridge device setting
dev tap

# Host name and port for the server (default port is 1194)
# note: replace with the correct values your server set up
remote gufide.mooo.com 1194

# Client does not need to bind to a specific local port
nobind

# Keep trying to resolve the host name of OpenVPN server.
## The windows GUI seems to dislike the following rule. 
##You may need to comment it out.
resolv-retry infinite

# Preserve state across restarts
persist-key
persist-tun

# SSL/TLS parameters - files created previously
ca ca.crt
cert client.crt
key client.key

# Since we specified the tls-auth for server, we need it for the client
# note: 0 = server, 1 = client
tls-auth ta.key 1

# Specify same cipher as server
cipher BF-CBC

# Use compression
comp-lzo

# Log verbosity (to help if there are problems)
verb 3

This is my server config file:

mode server
tls-server

local gufide.mooo.com ## ip/hostname of server
port 1194 ## default openvpn port
proto udp

#bridging directive
dev tap0 ## If you need multiple tap devices, add them here
up "/etc/openvpn/up.sh br0 tap0 1500"
down "/etc/openvpn/down.sh br0 tap0"

persist-key
persist-tun

#certificates and encryption
ca ca.crt
cert server.crt
key server.key  # This file should be kept secret
dh dh1024.pem
tls-auth ta.key 0 # This file is secret

cipher BF-CBC        # Blowfish (default)
comp-lzo

#DHCP Information
ifconfig-pool-persist ipp.txt
server-bridge 192.168.1.102 255.255.255.0 192.168.1.120 192.168.1.130
push "dhcp-option DNS 96.22.246.145" 
push "dhcp-option DOMAIN gufide.mooo.com"
max-clients 10 ## set this to the max number of clients that should be connected at a time

#log and security
user nobody
group nogroup
keepalive 10 120
status openvpn-status.log
verb 3

The client is a windows 7 machine with openvpn gui.

share|improve this question
1  
Are you certain that the ports are open on your firewalls? Are packets getting from the client to the server? Have you done a tcpdump on the server side? –  Zoredache Mar 27 '13 at 16:45
    
with tcpdump I got: tcpdump: no suitable device found –  user2104697 Mar 27 '13 at 17:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.