Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a virtualized server running 10.04 LTS that is no longer booting. We had a number of issues with our SAN that abruptly disconnected the storage from the virtual machine infrastructure and wreaked general havoc. The issue I began with was an error:

Target filesystem doesn't have /sbin/init

So I checked for the particular error and found that running boot-repair would be the best course of action. So I ran boot-repair.

When running boot repair I get an error:

/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).

and I am also presented with a grub prompt on restart (which makes sense since boot-repair doesn't seem to be writing the boot info properly). I can access (it is mounted and seems fine) the partition from a LiveCD and all the data is there so I am hopeful that this can be corrected.

The boot-repair log can be found at http://paste.ubuntu.com/5650377

A user on another post at ubuntuforums.org requested that I run:

dd if=/dev/sda5 bs=512 count=255 skip=1 of=/tmp/sda5.txt

The results of which can be found at https://gist.github.com/shanepinnell/5258498

Any and all help is greatly appreciated


Found a solution:

Once at a grub menu

  • grub> linux (hd0,1)/boot/vmlinuz-[tab to autocomplete] root=/dev/sda1
  • grub> initrd (hd0,1)/boot/initrd.img-[tab to autocomplete]
  • grub> boot

After a successful boot + sudo grub-mkconfig + sudo update-grub

Everything works now!

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.