Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a computer at a location that is currently without internet service. I just did a fresh install of XP SP3 and am in the process of loading basic software that will be required later. Among the software I loaded is Adobe Reader 9.1. I always disable automatic update checking for every program I install. My reasons are my own.

Adobe has made it difficult to disable automatic updates. It appears that I would have to have an internet connection and actually check for updates once before I can disable them using the UI provided me.

like this

All I get is a message (above) that makes me think I have to connect to the internet to disable automatic updates. Is there a registry setting to disable automatic updates to Adobe Reader, or how can I accomplish this without connecting to the internet?

Edit: It's not trying to do an automatic update on its own, yet. I am clicking on Help > Check for Updates in order to get to the dialog to allow me to disable automatic update checking (which will, yes, likely only occur once there is an internet connection).

share|improve this question

4 Answers 4

up vote 3 down vote accepted

The official way is to use Adobes Customization Wizard - it will help you deploy Reader properly and can do this for you easily. While you're at it, get the msi packaged version of Reader 9.1 and the 9.1.3 patch.

For the manual "hacker" the FeatureLockdown registry key seems to be working still in 9, check this article out.

REG ADD "HKLM\SOFTWARE\Policies\Adobe\Acrobat Reader\9.0\FeatureLockdown" /v bUpdater /d 0 /t REG_DWORD /f
share|improve this answer
    
This looks perfect, thank you for the help! –  eleven81 Aug 3 '09 at 18:27
    
Great. If you get the time I'd love to hear how it turned out - even with Adobes help, deploying their applications can be such a pain at times ^^ –  Oskar Duveborn Aug 3 '09 at 20:02

Interesting. I've never seen that message, despite having a LAN connected, but dialup for Internet machine at home! Most of the time the machine is running, there's no Internet connection. Adobe Updater only tries to update when I'm online.

share|improve this answer
    
It's not trying to update. I am clicking on Help > Check for Updates to get to the dialog to allow me to disable automatic update checking (which will, yes, likely only occur once there is an internet connection). Sorry for the confusion! –  eleven81 Aug 3 '09 at 16:23

You could add the host to which it is connecting to the hosts file in windows, so every time it tries to look up the address to get updates, you would redirect it to 127.0.0.1, so it times out instantly.

share|improve this answer

How about if you:

  1. install Adobe Reader on a machine which IS connected.
  2. Make sure it is fully updated.
  3. Disable the automatic updater.
  4. Use a flash drive to copy all the Adobe Reader files to the non-internet-enabled machine.

This also assumes that none of these updates are registry-related, but these steps are relatively easy to implement and the worst case scenario is you'd have to reinstall Adobe Reader.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.