Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an assignment that requires remote access into some Cisco routers. According to Netlab, it uses TCP port 23.

I'm unable to pass the port test. I'm on Windows 7, I've tried all major browsers. I've disabled Windows Firewall and even connected directly to the modem. My ISP is Cogeco but I've tried tethering to my iPhone (Rogers) which produced no success.

After some reading it was suggested to go into Windows Features in the control panel and turn on Telnet. I did that, and made sure to set the Telnet service to manual and start it in services.msc. Still, I'm unable to pass the port test.

I've checked this website: http://www.t1shopper.com/tools/port-scan/ and it confirms than I'm unable to connect to Port 23.

Would anyone have any suggestions? My timeslot for the lab is in a couple hours and I'm not sure why it is giving me such a hard time. I've managed to use this machine previously to do the lab, albeit on a different connection (not the school's though).

Here is the error message I'm getting:

aptest PING_IO_ERROR: Connection timed out: connect
aptest all ports failed
aptest callback (STATUS_NO_OPEN, null)
aptest js result=STATUS_NO_OPEN param1=null
share|improve this question

closed as off topic by joeqwerty, Zoredache, DanBig, SvW, Kenny Rasschaert Mar 29 '13 at 18:37

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

When they said to turn on telnet, they meant to install the telnet client, not the service. Once you have the telnet client installed open a command prompt and type in

telnet [servername]

if that doesn't work, download putty and give that a try.

Other than that there are so many unknowns about the environment. Are you supposed to be connecting to the router over the cloud or is there somewhere you are supposed to VPN to first?

share|improve this answer
    
I don't actually need to use a Telnet client to connect to the routers. It's a Java application that runs in the browser which gives remote access into the routers (ie I can see their terminals). The reason I'm worrying about Telnet is because it says it uses port 23, which is the telnet port. –  user1287523 Mar 29 '13 at 16:55
    
Port 23 is the remote port on the router NOT the local port on the Java or telnet client. –  joeqwerty Mar 29 '13 at 17:05
    
Is this a CBT? Like a java based virtual environment? I'd check to make sure your java environment is installed properly. –  Snowburnt Mar 29 '13 at 17:09
    
It is. But as I mentioned, I have been able to get it working on this exact same environment on a prior lab. –  user1287523 Mar 29 '13 at 17:14
    
If nothing has changed in your environment, then it sounds like an issue with the particular lab. I'd get in touch with the vendor and your instructor. –  Snowburnt Mar 29 '13 at 17:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.