Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Fetchmail polls an ISP server that is always congested (we don't own that server and can't fix it). 1 out of every 20 attempts, roughly, results in an authentication failure response from that server. It's not actually an authentication problem since it works the other 19 out of 20 items, its actually a busy response.

In any case, the net result is that we get 20-30 messages every day that say:

fetchmail authentication failed on ___

followed immediately by:

fetchmail authentication OK on ______

Is there any way to make fetchmail try several times before sending this message? Or to disable it completely for certain servers?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It may be possible to suppress the message by not running in daemon mode.

From https://lists.berlios.de/pipermail/fetchmail-users/2012-January/003031.html:

The workaround would be to use a shell script to emulate the "" mode, and not use it (because the e-mail warnings only get sent in daemon mode). You may have to use grep -v to kill the message there, too, if you don't want it in the logs (not shown in the example below) and redirect the remainder of the output into the log file, such as:

while true ; do
  fetchmail >>/home/users/srolinso/fetchmail/log/fetchmail_etg.log \
    -d0 \
    -f /home/users/srolinso/fetchmail/fetchmail_etg
  sleep 10
done
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.