Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am hosting php 5.2 on IIS 8. Yes, I know that's a horrible idea, but that is reality.

The server runs out of resources after our website is up for a few hours because for some reason php-cgi.exe opens up dozens of times:

enter image description here

What am I doing wrong? perhaps something wrong with the php.ini file?

Could this be caused by mssql_result not closing the connection?

I followed this nifty tutorial without luck http://www.iis.net/configreference/system.webserver/fastcgi/application

I have actually been able to limit the number of instances, but then all additional requests are getting processed very slowly.

share|improve this question
    
What does your config look like? –  AbsoluteƵERØ Mar 29 '13 at 22:30
    
do you mean the php.ini? –  Yuck Mar 29 '13 at 22:31
    
@cpattersonv1 here it is! pastebin.com/Gt4ZMSW0 –  Yuck Mar 29 '13 at 22:35
    
@cpattersonv1 is that what you wanted? –  Yuck Mar 29 '13 at 22:48
    
The fastcgi config. –  AbsoluteƵERØ Mar 29 '13 at 22:51
show 4 more comments

1 Answer

I think it's better for you to perform the installation automatically using the tools provided by Microsoft:

  1. Download the Microsoft Web Platform Installer.
  2. Check in Options that you'll use IIS (not IIS Express).
  3. Search for "php", select some version and click "Add".
  4. Click "Install".
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.