Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just installed directadmin on centos 5.8 , but its cant send out any email!

Internal send mail works right but can't send to gmail or yahoo etc or any other external domain.

This is the exim log:

2013-03-29 20:51:01 1ULk0b-0003L8-T5 => admin <admin@server.(mydomain).ir> F=<diradmin@server.(mydomain).ir> R=localuser T=local_delivery S=1072 
2013-03-29 20:51:01 1ULk0b-0003L8-T5 Completed 
2013-03-29 21:04:34 1ULXGj-0001Pr-QK mta5.am0.yahoodns.net [66.196.118.36] No route to host 
2013-03-29 21:04:37 1ULXGj-0001Pr-QK mta7.am0.yahoodns.net [66.196.118.34] No route to host 
2013-03-29 21:04:37 1ULXGj-0001Pr-QK == (myemail)@rocketmail.com R=lookuphost T=remote_smtp defer (113): No route to host – absfrm 2 hours ago
share|improve this question
    
What do the logs say? –  Jenny D Mar 30 '13 at 10:02
    
this is my exim log : 2013-03-29 20:51:01 1ULk0b-0003L8-T5 => admin <admin@server.(mydomain).ir> F=<diradmin@server.(mydomain).ir> R=localuser T=local_delivery S=1072 2013-03-29 20:51:01 1ULk0b-0003L8-T5 Completed 2013-03-29 21:04:34 1ULXGj-0001Pr-QK mta5.am0.yahoodns.net [66.196.118.36] No route to host 2013-03-29 21:04:37 1ULXGj-0001Pr-QK mta7.am0.yahoodns.net [66.196.118.34] No route to host 2013-03-29 21:04:37 1ULXGj-0001Pr-QK == (myemail)@rocketmail.com R=lookuphost T=remote_smtp defer (113): No route to host –  absfrm Mar 30 '13 at 10:11
    
Thanks, that's enough to start finding the answer. But it'd be great if next time you could add the logs to the question instead, it makes it easier to read. (I did that for you.) –  Jenny D Mar 30 '13 at 12:59
add comment

1 Answer

The logs tell you the problem - no route to host. There's something wrong with your network setup that makes your server unable to connect to other servers on the internet, outside of your own network. So start by checking your default route.

share|improve this answer
    
thank you.i fixed it by edit exim.conf and ad redstation datacenter parameters to it.but now i can't receive email! –  absfrm Mar 30 '13 at 15:47
    
Is there any chance your ISP is blocking inbound port 25. –  Jenny D Mar 30 '13 at 17:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.