Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This question already has an answer here:

I've set up an instance on EC2 of RHEL (I also tried the same with a CentOS AMI) and cannot seem to connect via my browser.

I can SSH in.

But when I put the IP into my browser I can't connect.

I tried adding to the default Security Group Http. I tried adding Http to the new Security Group created when the instance was created, and I tried creating a new group as well...

I feel like I'm missing something simple, but can't seem to find any references to what it might be anywhere.

EDIT Currently I have 3 security groups:

  • quicklaunch-1: TCP 22 (SSH) 0.0.0.0/0, 80 (HTTP) 0.0.0.0/0, 443 (HTTPS) 0.0.0.0/0
  • default: ICMP ALL sg-8adf34e1 (default) TCP 0 - 65535 sg-8adf34e1 (default), 80 (HTTP) 0.0.0.0/0, 443 (HTTPS) 0.0.0.0/0 UDP 0 - 65535 sg-8adf34e1 (default)
  • Web: ICMP Echo Reply 0.0.0.0/0, TCP 0 - 65535 0.0.0.0/0, 22 (SSH) 0.0.0.0/0, 80 (HTTP) 0.0.0.0/0, 443 (HTTPS) 0.0.0.0/0 UDP 0 - 65535 0.0.0.0/0, 53 (DNS) 0.0.0.0/0

I've tried with several different variations... same exact response.

share|improve this question

marked as duplicate by Jacob, Iain Mar 31 '13 at 22:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What web server are you using?... –  mossy Mar 31 '13 at 18:12
    
Apache, after the install I ran yum install httpd then service httpd start. I've been successful setting up CentOS 6 distros on VMWare... Haven't used EC2 yet. –  jackreichert Mar 31 '13 at 18:14
    
Is there more info I can include that would help diagnose my problem? –  jackreichert Mar 31 '13 at 18:16
    
You could tell us what happens when you try to visit the web site. –  Michael Hampton Mar 31 '13 at 18:19
1  
Did you open the port in the CentOS firewall? –  Michael Hampton Mar 31 '13 at 18:45

1 Answer 1

up vote 2 down vote accepted

In addition to the EC2 security group, your port 80 also needs to be opened in the CentOS firewall. You can use system-config-firewall-tui to do this from the root shell by selecting its Customize option.

system-config-firewall-tui

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.