Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a fresh instance on EC2 of "Linux/Unix, CentOS 6 | 64-bit Amazon Machine Image (AMI)"

This is what I did to get it running.

yum install wget 
wget http://repo.webtatic.com/yum/el6/latest.rpm 
sudo rpm -Uvh latest.rpm
yum repolist
yum update

sudo yum install httpd mod_ssl
sudo /usr/sbin/apachectl start
chkconfig --levels 235 httpd on

vi /etc/sysconfig/iptables
// add -A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT 
// add -A INPUT -m state --state NEW -m tcp -p tcp --dport 443 -j ACCEPT 
/etc/init.d/iptables restart

sudo yum install php54w php54w-mysql php54w-gd php54w-xml php54w-xmlrpc php54w-mbstring php54w-mcrypt php54w-pdo php54w-soap

When I get to the final command it fails because:

Error: mysql55-libs conflicts with mysql-libs-5.1.67-1.el6_3.x86_64
Error: Package: php54w-mcrypt-5.4.13-1.w6.x86_64 (webtatic)
           Requires: libmcrypt.so.4()(64bit)

I tried not installing php54w-mcrypt, but php54w-mysql still fails. If I try installing php-mysql (not php54w) it still fails.

Any ideas how to resolve this?

Edit: Is there an alternate repo to webtatic I can use that has the latest stable releases, that does work? Yum base doesn't include php 5.4, which I'd like to use.

share|improve this question
    
Curious what the solution is, but for now, decided to go with remi. If anyone has an insight into how to resolve this I'd still be very interested. –  jackreichert Apr 1 '13 at 1:00

3 Answers 3

As Electrawn mentions, the libmcrypt package is now in the Webtatic repo, it was depending on the EPEL repository, but not everyone has this installed.

As for the php54w-mysql installing MySQL 5.5 issue, this was resolved 6th May: http://www.webtatic.com/news/2013/05/latest-updates-php-5-4-14-5-3-24/

share|improve this answer

I ran into this issue, and sent an email to Andy who runs the webtatic repository. The libmcrypt missing dependency is now included in webtatic repo.

Turnaround on the email was 16 hours.

share|improve this answer
    
just a correction on that turnaround, 7 hours turnaround from your email. –  Andy May 22 '13 at 21:04

If you run into this issue installing php??w-mysql, try the following instead:

yum install php??w-mysqlnd

This will skip the dependency check.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.