Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Background

I moved this site from IIS6 WIN2K3 to WIN2K8R2 IIS7 and the site launches but I'm getting errors on lots of the links/main menu items.

Things I have already checked

  • application pool settings
  • db connection strings
  • Creds/permissions in place
  • installed the correct version of Ektron

Could this be a web.config Issue? I tried to look at the differences between IIS6 and IIS7, but didn't see anything obvious. Any help or clue will be appreciated!


Receiving the following error message

"Server Error in '/' Application.
The resource cannot be found
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /what.aspx

Version Information: Microsoft .NET Framework Version:2.0.50727.5466; ASP.NET Version:2.0.50727.5456

Also Receiving following errors

HTTP Error 404.0 - Not Found

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

Module
IIS Web Core 

Notification
MapRequestHandler 

Handler
StaticFile 

Error Code
0x80070002 

Requested URL
http://mydomain.com:80/participantsoftheyear/ 

Physical Path
C:\inetpub\mysitenamefolder\participantsoftheyear\ 

Logon Method
Anonymous 

Logon User
Anonymous 
share|improve this question

2 Answers 2

In short: how was the site migrated?

The files copied? Sites sometimes consist of settings outside web.config (for eg, Applications and Virtual Directories), which aren't physically on the disk.

(You can use a tool like the Web Deployment Tool to migrate a site and all settings)

The second message is telling you what's wrong.

Does the physical path exist, or was it previously a virtual directory?

share|improve this answer
up vote 0 down vote accepted

Finally figured out the cause it was all to do with compatibility between IIS 6 web config file and IIS 7 web config files. I had to comment out few things and it worked

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.