Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I upload my application on server, I'm getting a bunch of these warnings: PHP Warning: include_once(): Unable to allocate memory for pool...

I know, there are loads of tutorials how to solve this problem on your server, but the server where I have my application, is not mine - it´s public hosting. Therefore I´d like to ask, how can be this problem solved? Do I have to contact my hosting provider?

share|improve this question

closed as off topic by Jenny D, Dave M, Jacob, Khaled, Scott Pack Apr 2 '13 at 15:03

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 1 down vote accepted

It seems an APC bug, try to disable it on .htaccess (php_flag apc.cache_by_default Off) or increase the apc.shm_size parameter in the apc.ini file.

Perhaps you have to contact your hosting provider.

share|improve this answer
apc.shm_size=anything you want
//And you can try this to test you is APC operational
function is_file_cached($file) {
$info = apc_cache_info();
foreach ($info['cache_list'] as $cache) {
    if ($cache['filename'] == $file) return true;
return false;

Can help you if you can edit php.ini on you public hosting Using a TTL of 0 means that APC will flush all the cache when it runs out of memory. How ever I believe your hosting don't have most up to date php version and error is because APC bug or php-fpm problem with used php version

Useful would be to know your APC version running with php

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.