Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server with a few IPs. I only want ONE Host (A) record to point from its name to one IP, and not to any of the others, which I am using other names for.

I'm not sure what triggers it, but I can delete the extra Host (A) records and refresh and they're not there, and then come back a few minutes later and refresh and they're back. It may have been that I did ipconfig /flushdns or cleared the server DNS cache, or maybe it's something else, but in any case, how can I stop it?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Easiest way would be on the server in question in the Advanced TCP/IP settings under the DNS tab to uncheck the "Register this connection's addresses in DNS" for any NIC you DON'T want registered.

If you have a single NIC with multiple IPs then do the same thing, but then you'll need to add a static Host (A) record in DNS for the server to make sure an entry exists for the name/IP match you want used still.

Register this connection...

share|improve this answer
2  
Thanks Dan...(for all those spatial learners) –  TheCleaner Apr 2 '13 at 13:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.