Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Ubuntu 12.04.2 LTS on HP ProLiant server.

After recent update (using apt-get update and upgrade), it boots into black screen. BIOS Post screen still shows normally, but when the OS takes over the monitor, I get only black screen. It is working, I can connect to it through SSH from my windows notebook. At first I have tried to solve the problem myself using google, but nothing worked as expected and I am afraid I did more bad then good.

I kept all things done since problem started written in notepad on win. machine, but lost it all on forced restart by windows update. As far as I remember, I tried modifying grub config to boot with options "quiet splash nomodeset" and then I tried several ways to reinstall graphic drivers or xorg.

Tell me if you need to see any configs or logs (path including).

edit : I reinstalled the server in the end.

share|improve this question
    
You're more likely to get help here if you state a specific question. For example, "Why doesn't the display awake from sleep when I press enter?" or, "Why isn't my web server running, even though I can connect via ssh?" –  Craig Constantine Apr 2 '13 at 20:41
    
Are you watching this via a remote KVM or do you have local access to the server? Did you try to add "vga=normal" to your boot options? –  etagenklo Apr 6 '13 at 11:57

1 Answer 1

I had the same problem a month ago. With Ubuntu 12.04. BIOS was displayed normally.

On HP Proliant DL 3xx you have 2 VGA port. One on the front side and an other on the back side.

I used the back side VGA port. And when I simply connected the cable on the front side instead of the back one, it worked. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.