Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed memcached. Everything worked swimmingly until I restarted the system. I have no idea what went wrong, but after the restart, some files were missing. Main main problem is that I have and files missing.

I tried following the advice here. This lead me to the following error:

Warning: dl(): Unable to load dynamic library 
'/usr/local/lib/php/extensions/no-debug-non-zts-20090626/' -
    cannot open shared object file: 
      No such file or directory in /root/tmp/moduleEnabled.php on line 6

I can't run:

pecl install PDO

... because it ends with a huge error that I think is as a result of PDO actually being installed, but the files being missing or deleted.

I ran:

find / -name

And it came back with nothing. I ran the same command on another server, and it returned:


However, I also read this: "Do not use this, as PDO has been moved into core (the php source) so this pecl extension is dead." ... here, which leads me to believe that with PHP version 5.3.22 I no longer need to install PECL. If this is so, why is the extension not working when I enable it in php.ini?

PhpInfo says this:

Configure Command    './configure' '--disable-fileinfo' '**--disable-pdo**' 
'--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-gd-native-ttf'
'--enable-intl' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' 
'--enable-sockets' '--prefix=/usr' '--with-curl=/opt/curlssl/' 
'--with-freetype-dir=/usr' '--with-gd' '--with-icu-dir=/usr' 
'--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' 
'--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' 
'--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2/' 
'--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' 
'--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' 
'--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pic' 
'--with-png-dir=/usr' '--with-xmlrpc' '--with-xpm-dir=/usr' '--with-zlib' 

Clearly PDO is still disabled. Must I recompile PHP to enable it, perhaps? How do I do that?

Based on the the above, can anyone please advise me on how to get PDO to work with PHP 5.3.22 on my Centos Box?

share|improve this question
up vote 0 down vote accepted

My problem was that I installed PDO manually on a cPanel server. To fix the problem I simply selected the modules I needed in WHM and the problem was fixed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.