Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On Ubuntu Precise 12.04, the package osm2pgsql is currently at 0.70.5+r25090-2ubuntu2. However I need to install a newer version 0.80 but apt-get update does not provide the newer version.

Question: I found the 0.80 version in the Ubuntu quantal's repo at https://launchpad.net/ubuntu/+source/osm2pgsql/0.80.0+r27899-1ubuntu1, is there any way to install this when I'm on Ubuntu 12.04?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You can't install packages for one version of Ubuntu on another version, or more accurately, you REALLY shouldn't.

You will create a mess of dependencies that will need to be resolved, and can easily dig down so far into your system that you wind up with an unstable or unusable machine as a result.


If you need a particular version of some package you have three real options:

  1. Upgrade the OS to a release that distributes and supports the version of the package you need.

  2. Find someone who has packaged the software for your platform/version (check PPAs)

  3. Build it yourself and assemble a package.

share|improve this answer
    
backporting quite often is as easy as adding a new changelog entry in debian/changelog. or via dch. –  Matt Joyce Apr 3 '13 at 19:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.