Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a FreeBSD lab machine that is regularly connected and disconnected from the network, sometimes to borrow the port temporarily for another machine and other times to test the ability of certain software to recover from losing the network connection. It is possible for the machine to be disconnected for several hours at a time.

When I do this, I get screens (and log files) full of de0: link down: cable problem?.

There is some discussion about this on this email list in 2006, but there is no solution posted. As that questioner said in a follow-up, I do not want to disable the interface every time.


Note: The Question Title filter prevents the word "problem" from appearing in the title of a question, hence the non-English character in the title.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You can fix this issue, by compiling and installing a custom kernel.

Edit the file /usr/src/sys/dev/de/if_de.c, disabling the following line

device_printf(sc->tulip_dev, "link down: cable problem?\n");

as follows:

#ifdef CABLE_MESSAGES
device_printf(sc->tulip_dev, "link down: cable problem?\n");
#endif
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.