Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to set up a vagrant. Host is Ubuntu 12.10. Here's my vagrant file: do |config|

    config.vm.share_folder("v-root", "/vagrant", ".", :nfs => true) :bridged, :bridge => "eth0"

    config.vm.define "restserver" do |chefs_config| = "precise64"
        chefs_config.vm.box_url = ""
        chefs_config.vm.host_name = "restserver" :hostonly, ""
        chefs_config.vm.forward_port 80, 8080

        config.vm.provision :chef_solo do |chef|

            chef.log_level = :debug

            chef.cookbooks_path = "cookbooks"

            chef.add_recipe "apt"
            chef.add_recipe "base"
            chef.add_recipe "mongodb::default"
            chef.add_recipe "nginx"

The problem is that my internet access from within the vagrant is terrible. It's very slow. I think the routing tables might be messed up. Here's the output from route -n:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 eth0         UG    100    0        0 eth0   U     0      0        0 eth0   U     0      0        0 eth1   U     0      0        0 eth2

There are 2 routes to the default destination, although on the same NIC and to the same gateway. But perhaps this is causing an issue. At least that's what I thought but deleting the first default route doesn't help.

I need host-only networking so the nfs share will work. NAT is used for the port forwarding, and I've added the bridged network to try to give this guest access to the internet.

Has anyone any idea what's wrong? DNS is very slow to resolve, and it's slow to download anything from the internet.

share|improve this question

2 Answers 2

Running Version 2 of the Vagrant config?

Sarah's provided the answer which is to use the NAT hosts DNS resolver as it's faster and will help speed things up.

However, in Version 2 of the vagrant config which is what most people are using now you'll have to do add following within your 'Vagrantfile' which will force the VM to uses NAT'd DNS:

config.vm.provider "virtualbox" do |v|
   v.customize ["modifyvm", :id, "--natdnshostresolver1", "on"]
   v.customize ["modifyvm", :id, "--natdnsproxy1", "on"]

You can tell if you're using v2 config if you have the following lines or something in the top of your Vagrantfile

Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
share|improve this answer
This should be the right answer – Dbugger Sep 3 '14 at 15:24
I tried to boost my vagrant network and it worked, but I had issues with e.g. pulling docker images because of too much DNS lookups. Thus I had to remove this line v.customize ["modifyvm", :id, "--natdnsproxy1", "on"] means I just have this added to my Vagrantfile v.customize ["modifyvm", :id, "--natdnshostresolver1", "on"] Looks like the host resolver is boosting the network performance for some reason and the DNS proxy frags some tools. – zyndiecate Jan 9 at 18:26
up vote 18 down vote accepted


Add the following to the vagrant config:

config.vm.customize ["modifyvm", :id, "--natdnshostresolver1", "on"]

See here for more: Vagrant / virtualbox DNS not working

share|improve this answer
This almost fixed it for me, except that there wasn't a customize method on config.vm. Instead, on my ` config.vm.provider :virtualbox do |vb|` section, I added this: vb.customize ["modifyvm", :id, "--natdnshostresolver1", "on"] – Ovid Oct 17 '13 at 6:21
The answer provided by 'sarah' is for the old VagrantFile configuration syntax, and the one provided by 'Ovid' is for the newer configuration syntax. You can tell if you're using the newer syntax by seeing if your configuration file includes Vagrant.configure(2) at the top (note the 2) – caseyamcl Jan 3 '14 at 18:02
almost. this works for me vagrant 1.4.3 – choonkeat Feb 26 '14 at 2:01
I'm on Fedora 22 and setting this to "off" was my solution. – Christopher Markieta Oct 13 at 22:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.