Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having issues installing MMS. I have it installed on an agent. I can connect to a mongos instance from the server the agent is installed on.

In the agent log, I see the following messages repeated:

Problem collecting blocking data from: [internalservername]:27017 - exception: Traceback (most recent call last): 
File "/home/web/mms-agent/blockingStats.py", line 57, in run monitorConn = self.mmsAgent.getDbConnection( self.hostKey ) 
File "/home/web/mms-agent/mmsAgent.py", line 107, in getDbConnection return pymongo.Connection( hostDef['mongoUri'] , slave_okay=True, document_class=bson.son.SON ) 
File "/home/web/.virtualenvs/web/lib/python2.6/site-packages/pymongo/connection.py", line 180, in __init__ 
File "/home/web/.virtualenvs/web/lib/python2.6/site-packages/pymongo/mongo_client.py", line 274, in __init__ ConnectionFailure: unknown encoding: idna

Getting the same error for non-blocking data. Not sure what the unknown encoding error is. However, some additional information that may or not be relevant, the lower two lines in the log come from the mongo host that is using python 2.6.5 in an older ubuntu, while the agent is installed on a newer ubuntu version with python 2.7.3

Does anyone have any idea what the problem might be?

Many thanks in advance.

share|improve this question

1 Answer 1

Found the problem. This error log was coming from an agent I had attempted to install on a staging server a while back which I guess was blocking the newer agent. As soon as I shut down the agent on the staging server, the data started coming in through the new agent I installed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.