Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I run:

yum install php-intl

I get this error:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.as29550.net
 * epel: ftp.nluug.nl
 * extras: mirror.as29550.net
 * updates: mirror.for.me.uk
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-intl.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-22.el6 for package: php-intl-5.3.3-22.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-intl-5.3.3-22.el6.x86_64 (base)
           Requires: php-common(x86-64) = 5.3.3-22.el6
           Installed: php-common-5.3.14-1.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.3.14-1.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Any ideas how to get around this problem?

I tried:

yum install php-common-5.3.3-22.el6.x86_64

It says it's already installed.

share|improve this question
add comment

2 Answers

Try to disable repo remi,remove installed php-comon with yum remove php-common

and then install:

yum install php-common php-intl

Can you put the output from

php -v

share|improve this answer
add comment

The problem seems to be that you're running a non-standard version of PHP, from the remi repository at http://rpms.famillecollet.com/el5.i386/ . The real answer is: don't do that; if you need a more up-to-date PHP, upgrade to CentOS 6. But that's probably not much help to you right now, though if you really don't need the updated PHP, downgrade as B14D3 advises in his answer.

Assuming you do need the remi PHP, then there is a php-intl package of the right version in the remi repository; I'm not quite sure why your yum isn't picking it up. If you look in the relevant file in /etc/yum.repos.d, is the a priority= statement that might be causing the base/updates repos to override the remi one? Or is the repository disabled (enabled=0)? Could you post the contents of the relevant /etc/yum.repos.d file?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.