Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The times on my arch linux workstation got messed up, so I set the system time with date and then the hardware time with

sudo hwclock --systohc --utc

Now the hwclock gives:

Do 04 Apr 2013 14:12:48 CEST  -0.641471 seconds

but I want it to use UTC, which would be 12:12:48! How do I achieve this?

edit:

some additional weirdness:

$ hwclock --utc
Do 04 Apr 2013 14:20:56 CEST  -0.188214 seconds
$ hwclock --localtime
Do 04 Apr 2013 12:21:01 CEST  -0.438205 seconds
$ date -u
Do 4. Apr 12:21:11 UTC 2013
$ date
Do 4. Apr 14:21:16 CEST 2013

utc and localtime seems to be confused by hwclock...

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Yep, in Linux you can use hwclock --systohc, and pay your attention to its manual saying that «…

The time shown is always in local time, even if you keep your Hardware Clock in Coordinated Universal Time. See the --utc option. Showing the Hardware Clock time is the default when no function is specified.

…»

And, BTW, my man hwclock also reveals option --debug which would really help you in your search of the truth.

share|improve this answer
    
ahrghhh! so hwclock --localtime shows the local time assuming that the hardware clock is using localtime, which results in something that appears wrong at firts sight!!! Fair enough... –  steffen Apr 4 '13 at 12:39
    
@steffen, see update regarding --debug also… –  poige Apr 4 '13 at 12:41
    
yep, that makes it clear... it is confusing, though. With date the option changes what is to be desplayed, while with hwclock the option changes the assumption in order to calculate the displayed time. –  steffen Apr 4 '13 at 12:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.